Rockbox

Tasklist

FS#6531 - recursive playlists order by file date not filename

Attached to Project: Rockbox
Opened by Auz (Auz) - Friday, 12 January 2007, 23:37 GMT
Last edited by Daniel Stenberg (bagder) - Tuesday, 31 July 2007, 08:11 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you make a recursive playlist by being in a directory, pressing the A-B button and navigating to Playlist Options then Create Playlist, the songs are ordered by file creation/modification instead of filename, in spite of Sort Files being alphabetical.

For example, I copied the 12 songs from Laibach's WAT to /music/Laibach/WAT. Due to track 7 having a colon in the name, I had to skip it initially, rename it and copy it after the other tracks. When I made the playlist, it looked like this:

/music/Laibach/WAT/01-B Mashina.ogg
/music/Laibach/WAT/02-Tanz mit Laibach.ogg
/music/Laibach/WAT/03-Du bist unser.ogg
/music/Laibach/WAT/04-Achtung!.ogg
/music/Laibach/WAT/05-Ende.ogg
/music/Laibach/WAT/06-Now You Will Pay.ogg
/music/Laibach/WAT/08-Das Spiel ist aus.ogg
/music/Laibach/WAT/09-Satanic Versus.ogg
/music/Laibach/WAT/10-The Great Divide.ogg
/music/Laibach/WAT/11-WAT.ogg
/music/Laibach/WAT/12-Anti-Semitism.ogg
/music/Laibach/WAT/07-Hell Symmetry.ogg
This task depends upon

Closed by  Daniel Stenberg (bagder)
Tuesday, 31 July 2007, 08:11 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response since feb
Comment by Tom Ross (midgey34) - Sunday, 21 January 2007, 18:41 GMT
Can't reproduce the issue here. I created a directory structure and filenames identical to yours and I got a correctly ordered playlist. Please attach your m3u8 file that was created.
Comment by Auz (Auz) - Sunday, 21 January 2007, 20:34 GMT
Here we go.
(application/octet-stream)    WAT.m3u8 (0.5 KiB)
Comment by Jonathan Gordon (jdgordon) - Monday, 05 February 2007, 12:05 GMT
Do you have the file browser set to order by date? (general settings > file view > sort directories)
Comment by Auz (Auz) - Monday, 05 February 2007, 19:42 GMT
Both directories and files are set to Alphabetical.
Comment by Auz (Auz) - Monday, 05 February 2007, 22:09 GMT
Here's another one, ripped today with KAudioCreator CD Ripper to ogg. Tagged using Picard from MusicBrainz. Then, to copy I had to rename track 7 because it has a question mark in it.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 07 February 2007, 00:54 GMT
have you tried resetting your settings? what is the build version?
I just tried with latest svn and couldnt reproduce it.

Loading...