Rockbox

Tasklist

FS#6552 - Battery Life on Iriver H10 20G

Attached to Project: Rockbox
Opened by Robert Cotey (coteyr) - Friday, 19 January 2007, 15:21 GMT
Last edited by Nils Wallménius (nls) - Wednesday, 29 July 2009, 12:58 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This bug report is more to help what assistance I can. The H10's battery life does not seem to be reporting correctly on the status bar or WPS screens. It drop quickly from 100% to 14% then can take a considerably longer time to drop from 14% to 0% (when the unit will not power on anymore). While testing I discovered that if I boot into the OF the battery meter in OF reports only 4 stages. If we take them to mean 100-75, 50-74, 25-49, 0-24 then while rockbox is reporting 14% Battery life the OF still reports either 100-75 or 50-74.

The OF may be doing some odd calculations to "pad" its battery life display (i.e mesurments in voltage are not percents but ranges larger ranges for the first segment and range size decreseing as the battery drains more.)

Either way rockbox batery meter does not scale down from 100% to 0% evenly (takeing into concideration voltage diffrences when more hardware is running).

One thread I found on the topic states that it's just a matter of geting calabration data to the devs. I would be more then happy to provide the calabration data if I knew how. for Now I will start attaching battery_bench.txt files unless told otherwise.

As a note I have the "re-mix" blue version of the H10, if it has a diffrent battery would that change the battery display in this mannor.

I am going to find out what I can about the "re-mix" version of this player.

If you ned any other info just let me know.
This task depends upon

Closed by  Nils Wallménius (nls)
Wednesday, 29 July 2009, 12:58 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Really old, likely fixed, no confirmation either way...
Comment by Robert Cotey (coteyr) - Friday, 19 January 2007, 15:51 GMT
The H10 supposadly has the same stock battery as the H300
the h300 stock battery is reported as a 1300mAh Li-polymer battery. The H10's default battery capacty in rockbox is 1550mAh.
Comment by Nils Wallménius (nls) - Friday, 19 January 2007, 17:25 GMT
As you said the cause of the strange readings is probably that it isn't calibrated correctly.
According to this page http://www.rockbox.org/twiki/bin/view/Main/IriverH10HardwareComponents
the battery is in fact 1550mAh.
Comment by Robert Cotey (coteyr) - Saturday, 20 January 2007, 09:42 GMT
First file
Comment by Barry Wardell (barrywardell) - Saturday, 20 January 2007, 21:12 GMT
The H10 20GB has a 1550mAh battery. I calibrated the battery display in Rockbox for this battery. I also calibrated the battery display for 5/6GB models which have a 820mAh battery.
I'm surprised that they're reading so wrong for you. What model do you have? Has the battery reading always been so bad?
Comment by Robert Cotey (coteyr) - Sunday, 21 January 2007, 00:54 GMT
I have the Remix-Blue (20G) version with the SRS tattoo (not sticker).

AS far as I can tell yes the battery has always been this lop-sided but I just got this device (it's new). The Device runs for a little of 7 hours now in rockbox after  FS#6421 .

In OF it runs for 14-16 hours (they say 16 but I have gotten 14 myself) The poor battery preformance is most likely due to boosting not working and thats already being looked at. The only part I am consirened with here is the battery meter (just making sure we are on the same page, it seems like we are but Just making sure.)

If I am reading the attached file correctly it took:

100-90 26 mins
90-80 54 mins
80-70 20 mins
70-60 50 mins
60-50 50 mins
50-40 1:27 mins
40-30 42 mins
30-20 28 Mins
20-10 2:00 mins
10-0(power off) 1 hour

almost the entire time below 10 the battery reads 0

when added up this shows
200 mins to get to 50%
283 mins to get from 50% to 0

357 mins above 20%
180 mins below 20%

total minuets 537

time above 20% 66.4%
time below 20% 33.5%




Oddly enough the 80-70 span was very short as was the 30-20 span. However the device did keep going from a low reading to a high reading. This could indicate additonal hardware (or just about anything) increseing the voltage reading.

If you were to tell me that thats the way the hard ware works and that the percentages do no corolate to time remaining (though I know they do not in a direct manor) I would beleve it. As I stated I think the OF must be doing some kind of padding to make theirs come out so you spend an equal amount of time in each bar.

however it is my understanding that With LiON battries that they spend a majority of their time about the 50% line then sink like a rock when they fall below it.

Comment by Johnathon Mihalop (Soul-Slayer) - Monday, 30 July 2007, 23:51 GMT
Small patch to attempt to better calibrate the % remaining reading on the H10 20gb. Closes this bug report.
Comment by Barry Wardell (barrywardell) - Tuesday, 31 July 2007, 09:42 GMT
Why is the 10% value lower than the first one (373<376)? That doesn't seem quite right.
Comment by Johnathon Mihalop (Soul-Slayer) - Tuesday, 31 July 2007, 14:15 GMT
Ack sorry, typoed =$, should be 367



Comment by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 01:24 GMT
I have a feeling this has been corrected in SVN but can someone confirm?
Comment by Andree Buschmann (Buschel) - Tuesday, 08 July 2008, 06:30 GMT
In svn the settings are different to the patch above. A current batterybench file would be helpful to check for proper settings.
Comment by Jonas Häggqvist (rasher) - Thursday, 11 December 2008, 17:39 GMT
Can anyone confirm or deny that this has been fixed in SVN?
Comment by Andree Buschmann (Buschel) - Sunday, 22 February 2009, 16:40 GMT
I would close this as outdated.

Loading...