Rockbox

Tasklist

FS#6629 - ipod bootloader fails to load Apple Firmware

Attached to Project: Rockbox
Opened by Dave Chapman (linuxstb) - Wednesday, 07 February 2007, 07:07 GMT
Last edited by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 02:19 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System iPod 4G Grayscale
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This problem appears to affect the 4G Grayscale and both generations of mini - the latest bootloader installed with the latest version of ipodpatcher fails to start the Apple firmware.

To help isolate the problem, it would be useful if users of the above devices could try the following tests, restoring a clean firmware partition before each attempt. Please report your findings here.

1) Install the latest bootloader with the latest ipodpatcher.

2) Install the old bootloader-????.bin bootloader from http://download.rockbox.org/bootloader/ipod/ using the latest ipodpatcher. You need to use the "-ab" option instead of "-a" to add a .bin format bootloader.

3) Install the ipodlinux loader2 with the latest ipodpatcher (again, the -ab option is needed).

4) Install the latest SVN bootloader, but using the old ipod_fw/ipodpatcher installation method. Use the links on the old IpodInstallation / IpodInstallationFromMacOSX / IpodInstallationFromLinux wiki pages for the executables. These instructions require a bootloader in ".bin" format, which if you build it yourself from SVN, you can find in the bootloader/ sub-directory in your build directory (called bootloader.bin).

For each test, does Rockbox load correctly, and does the original firmware load correctly? If the original firmware fails, can you note if it seems to fail in the same way, or if it looks like a different problem?
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Monday, 31 March 2008, 02:19 GMT
Reason for closing:  Out of Date
Additional comments about closing:  I'm with Bagder, and the tracker is cluterred enough.
Comment by Mike Miller (mikeage) - Wednesday, 07 February 2007, 09:24 GMT
1. Rockbox: Boots. Apple: Doesn't boot (loading original firmware, click, then reboot)
2. Rockbox: Boots. Apple: Doesn't boot (loading original firmware, click, then reboot)
3. Rockbox: Boots. Apple: Boots
4. Didn't test
5. www.apple.com/support/ipod
6. Rockbox: Boots. Apple: Boots
7. Hangs with just the apple icon visible (forever)

I didn't understand exactly what you wanted done for step 4 (did you want me to try what I did with test 6, but using the new bin from SVN? I can't compile right now... where can I find one?)

In test 5, I flashed the old bootloader only using the old ipodpatcher
In test 6, I used ipod_fw.exe -g 4g -o rockboot.bin -i apple_os.bin bootloader-4g.bin, and then flashed the rockboot.bin that it created.
In test 7, I attempted to flash the rockboot.bin created in 6 using the new ipodpatcher (and the ab option)
Comment by Dave Chapman (linuxstb) - Wednesday, 07 February 2007, 10:43 GMT
Your tests 5 and 7 wouldn't work - you're creating invalid firmware partitions.

Your test 6 should be the same as the old installation instructions, which are known to work. But it's useful to have that confirmed.

I'm attaching a bootloader.bin (the latest bootloader-ipod4g.ipod bootloader, but in .bin format) file for the 4g greyscale which you can use for test 4. This test is to help identify whether the new bootloader is the issue, or ipodpatcher.

Thanks.
Comment by Mike Miller (mikeage) - Wednesday, 07 February 2007, 11:09 GMT
Tested... it boots Rockbox, but not Apple.

In step two, was I supposed to use ipod_fw, or just run ipodpatcher <number> -ab bootloader-4g.bin ? (I just ran ipodpatcher)
Comment by Dave Chapman (linuxstb) - Wednesday, 07 February 2007, 11:24 GMT
Thanks.

Your test 2 was correct - just running the latest ipodpatcher with -ab bootloader-4g.bin.

That seems to confirm the following:

1) The latest Rockbox bootloader fails to load the original firmware, regardless of installation method.
2) The latest ipodpatcher breaks loading the original firmware for the old Rockbox bootloader, but not for loader2.

But in all cases, Rockbox itself boots fine.

Any further clues would be very welcome...
Comment by Daniel Ankers (dan_a) - Thursday, 08 February 2007, 01:14 GMT
Using the old ipodpatcher / ipod_fw method, I have tracked down the time that this started happening to somewhere between r10221 and r10390. I will do further testing soon.
Comment by Daniel Ankers (dan_a) - Thursday, 08 February 2007, 01:28 GMT
The problem appears to have been introduced with r10275.
Comment by Daniel Ankers (dan_a) - Thursday, 08 February 2007, 01:55 GMT
Ignore the last two comments. I am not able to reproduce those results, so must have been doing flawed testing. All bootloader builds up to r10390 seem OK.
Comment by Daniel Ankers (dan_a) - Thursday, 08 February 2007, 10:16 GMT
Loading the original firmware was broken by something in r10958 - "New scheduler, with priorities for swcodec platforms. Frequent task switching should be more efficient and tasks are stored in linked lists to eliminate unnecessary task switching to improve performance. Audio should no longer skip on swcodec targets caused by too CPU hungry UI thread or background threads."
Comment by Dave Chapman (linuxstb) - Friday, 20 April 2007, 23:02 GMT
The symptoms of this bug disappeared with commit 12631 on 5th March 2007. But we never discovered the real cause of the problem, so I think this task should remain open.
Comment by Daniel Stenberg (bagder) - Monday, 30 July 2007, 08:40 GMT
Why? If the bug no longer happens, I think we should rather close this and open a new bug or reopen this in case it hits us again!

Loading...