Rockbox

Tasklist

FS#6770 - No USB mode if you plug the cable when device is Off

Attached to Project: Rockbox
Opened by Lini Ini Mini (lini) - Friday, 09 March 2007, 06:19 GMT
Last edited by Marc Guay (Marc_Guay) - Tuesday, 01 April 2008, 12:41 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you plug the USB cable when the device is Off, the expected behavior is to boot Rockbox, then immediately switch to USB mode (charging, transferring files, etc.). However this does not happen with the recent daily builds. If I plug in the dock cable when my ipod is Off, it boots rockbox and does not detect the USB connection (often it also freezes). I have to restart the ipod and manually put it into disk mode to charge/transfer files.

Note that USB is properly detected if I plug the cable after Rockbox is started.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Tuesday, 01 April 2008, 12:41 GMT
Reason for closing:  Fixed
2008-05-18: A request to re-open the task has been made. Reason for request: r17468 firmware/drivers/ata.c firmware/thread.c The problem came to happen again because of this updates.
Comment by brent (countrymike) - Wednesday, 28 March 2007, 00:12 GMT
I've had this happen on the last two dailys i've installed (Ver. r12687-070309 and above) on an iPod 5G Video (30G). Have to reboot machine then plug in cable after it's running. Also got this error today.. not sure if it's related to the crash or not:

"Error accessing playlist control file"

and the artist name and song name were listed as - root:root
Comment by Lini Ini Mini (lini) - Wednesday, 04 April 2007, 12:32 GMT
still happens for me too. I tried reinstalling (deleting the .rockbox folder and rockbox.ipod and extracting a SVN build) but the same issue happens - if I plug the cable when the ipod is off, rockbox boots but does not go into disk mode. Instead the playback resumes (I have set resume playback as startup screen) and the screen and clickwheel are stuck.

I am using a simple workaround for now - before i plug the usb cable i switch hold ON, which boots the default firmware, which in turn goes to disk mode shortly afterwards.
Comment by Anton Romanov (theli) - Thursday, 03 May 2007, 17:39 GMT
i have similar behavior on mini2g
though after powering on rb shows usb logo and stays at it for ever... also disk access icon is on too ....
if i unplug usb then rb works if there where no usb at all.... if then i insert usb again rb reboots into disk mode successfully

bootloader as of May,6 (current on download.rockbox) happens for me for a long time (now with 2007-05-03 12:39 build)

reproducible always
Comment by Martin (mrvanes) - Thursday, 04 October 2007, 09:40 GMT
I have exactly the same(?) problem with my IpodVideo 80G (5.5G).
USB works if I boot Rockbox and then plug in the USB cable, it allways fails if I plug in the cable while the device is off.
What happens is that Rockbox boots after plugging in the cable, and than hangs on the main menu with HD icon on (and audibly on). I can't scroll, but backlight does react to touching the scrollwheel.
Original Rockbox firmware of 3-okt-2007, bootloader reinstalled couple of days ago.
Comment by omoha (omoha) - Saturday, 17 November 2007, 04:44 GMT
The problem seems to happen when "Directory Cashe" is effective.
Comment by Martin (mrvanes) - Saturday, 17 November 2007, 09:38 GMT
Thx for the workaround! :)
I can confirm this is resolved by switching off Directory Caching, using r15617-071114.
Comment by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 02:49 GMT
Can anyone confirm or deny if this is still happening?
Comment by Martin (mrvanes) - Monday, 31 March 2008, 11:05 GMT
Directory caching on and 5/5 successfull USB connects. Seems to be fixed.
Comment by Martin (mrvanes) - Monday, 31 March 2008, 11:07 GMT
Forgot to mention build: 16500-080303
Comment by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 11:43 GMT
Could you try it with the most recent build, please?
Comment by Martin (mrvanes) - Tuesday, 01 April 2008, 12:35 GMT
r16908M-080401 still works ok (directory cache on, USB connect correctly boots Ipod into USB mode).
Comment by Anton Romanov (theli) - Tuesday, 01 April 2008, 12:36 GMT
seem to work for me on my mini2g

Loading...