Rockbox

Tasklist

FS#6827 - Pictures disappearing under text

Attached to Project: Rockbox
Opened by Richard Hoyle (rah) - Wednesday, 14 March 2007, 18:05 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Sunday, 18 November 2007, 13:53 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

A change made on 4th/5th March to apps/gui/gwps-common.c has broken a
theme I use on the H3x0.

In my theme's wps file, I have a text field that does this:

%ar%?rr<0|1|2|3|4|5|6|7|8|9>

I have two conditional graphics below this of the form:
%?fc<%xdb|%xdc|%xdd||%xde|%xdf|%xdg|%xdh|%xdi|%xdj>
%?fv<%xdl|%xdm>

These graphics display for a fraction of a second a the beginning
of a track, then disappear.

The changes made to gwps-common.c are as follows:


@@ -922,11 +922,12 @@
switch(tag[1])
{
case 'p': /* Playcount */
- *flags |= WPS_REFRESH_STATIC;
+ *flags |= WPS_REFRESH_DYNAMIC;
+ *intval = cid3->playcount+1;
snprintf(buf, buf_size, "%ld", cid3->playcount);
return buf;
case 'r': /* Rating */
- *flags |= WPS_REFRESH_STATIC;
+ *flags |= WPS_REFRESH_DYNAMIC;
*intval = cid3->rating+1;
snprintf(buf, buf_size, "%d", cid3->rating);
return buf;

###

Rolling back to the pre-patched gwps-common.c, without the changes
above, fixes the problem. I have two themes like this which are
broken in this way.

Thanks for Rockbox.

===Rich
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Sunday, 18 November 2007, 13:53 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#6056 
Comment by Jonathan Gordon (jdgordon) - Thursday, 05 April 2007, 13:50 GMT
is this still a problem with the new wps code?
Comment by Nicolas Pennequin (nicolas_p) - Wednesday, 11 April 2007, 17:21 GMT
I think the problem simply is that the reporter has graphics displayed under texts. After the change, the text was made to update more often than the graphics (rr becomes dynamic whereas fc and fv are static), so the graphics disappear when the line is cleared to update the text. This is a more general bug with pictures in the WPS code.
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 18 November 2007, 13:53 GMT
Solution: put the conditionals on the same line as the %?rr conditional:

%ar%?rr<0|1|2|3|4|5|6|7|8|9>%?fc<%xdb|%xdc|%xdd||%xde|%xdf|%xdg|%xdh|%xdi|%xdj>%?fv<%xdl|%xdm>

That way, they'll be updated just as often as the %?rr conditional, which will make them stop disappearing.

I'm closing this as a dupe of  FS#6056 , which is basically the same "static vs. dynamic" issue.

Loading...