Rockbox

Tasklist

FS#6965 - Issues when Start Screen set to Resume Playback\\Recent Bookmarks

Attached to Project: Rockbox
Opened by Frank Grisafi (JobVanDam) - Tuesday, 03 April 2007, 23:53 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 05 April 2007, 03:00 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity High
Priority High
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When setting the Start Screen to Resume Playback it loads fine for the first part (original firmware loading screen, Rockbox bootsplash image). Then after it displays "Loading..." for roughly 45secs-60secs.

Setting the Start Screen to anything else makes it have a normal load time except Recent Bookmarks (when Bookmarks is empty, on startup it crashes the player and the causes the disk to thrash heavily).

Directory Cache doesn't have any effect on this.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 05 April 2007, 03:01 GMT
Reason for closing:  Fixed
Comment by Jonathan Gordon (jdgordon) - Wednesday, 04 April 2007, 09:55 GMT
What does it do after saying "Loading..." ? does it crash or start the music?
what does it do if you set the start screen to the main menu and press play?

As for the bookmarks, I just checked and this indeed is a bug. Hopefully ill fix this tonight
Comment by Frank Grisafi (JobVanDam) - Thursday, 05 April 2007, 02:56 GMT
OOOOooooohhhhh it been upgraded to high! Don't I feel special, honestly I do. Sorry.

After is says "Loading..." it does go to the WPS and play music normally.
When the Start Screen is set to the Main Menu on my Gigabeat I just push the Power button and it goes to the WPS and plays music normally. When I select Resume Playback on the Main Menu, again, it goes to the WPS and plays music normally.

All load times are normal after that first initial long loading. Also when the Start Screen is set to Main Menu load times are normal.
Comment by Jonathan Gordon (jdgordon) - Thursday, 05 April 2007, 03:01 GMT
just reoepend to reply....
That is all expected behaviour... the cpu is more busy during the fist 30s of boot so it can take a while to start music...
but the bookmakrs bug which actually was a problem is fixed

Loading...