Rockbox

Tasklist

FS#6974 - ogg albums don't appear in "album artist" view

Attached to Project: Rockbox
Opened by bart nagel (tremby) - Thursday, 05 April 2007, 09:33 GMT
Last edited by Marc Guay (Marc_Guay) - Monday, 31 March 2008, 22:09 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

not technically id3, but that's the closest category i could find.

may affect all players – i only have an X5 on which to test.

all my ogg albums are failing to appear in the "album artist" sorting mode. mp3 albums show as they should. ogg albums do, however, appear in the "album" view.

in case it's my fault and i've tagged them incorrectly, here's an ogginfo output:
«tremby@tremendo:~/media/music/The Livid/2002 - Fear of Fading»$ ogginfo 01\\ The\\ Day\\ I\\ Understood.ogg
Processing file "01 The Day I Understood.ogg"...

New logical stream (#1, serial: 241c36f2): type vorbis
Vorbis headers parsed for stream 1, information follows...
Version: 0
Vendor: Xiph.Org libVorbis I 20050304
Channels: 2
Rate: 44100

Nominal bitrate: 192.000000 kb/s
Upper bitrate not set
Lower bitrate not set
User comments section follows...
title=The Day I Understood
artist=The Livid
date=2002
album=Fear of Fading
tracknumber=01
Vorbis stream 1:
Total data length: 5260234 bytes
Playback length: 3m:51.266s
Average bitrate: 181.962548 kb/s
Logical stream 1 ended
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Monday, 31 March 2008, 22:09 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  User confusion.
Comment by Robert Kukla (roolku) - Thursday, 05 April 2007, 15:00 GMT
Are you sure your ogg files have an "Album Artist" "Albumartist" or "Ensemble" tag? Your ogginfo doesn't show it (but I don't know if it is supposed to).

If yes, could you please attach a very short example here, so I can check it out?

There was a suggestion to use the artist tag if the albumartist is missing, but I am in to minds if this would be desirable. (seems easy enough to implement).
Comment by bart nagel (tremby) - Thursday, 05 April 2007, 18:52 GMT
no, they're not tagged with albumartist. i was under the impression albumartist was just for compilation discs and seems like needless duplication for most albums. i do note, however, that the "artist" view as opposed to "album artist" functions as i expected "album artist" to – all albums (mp3 and ogg alike) are showing up.
Comment by Tom Ross (midgey34) - Friday, 03 August 2007, 05:48 GMT
I'm not sure this was a bug since the files weren't tagged with albumartist. It seems like the user wanted to copy the data from the artist tag which was done in r13710. Is there an issue, or can this be closed?

Loading...