Rockbox

Tasklist

FS#7022 - A set of functions for semi-transparency in plugins.

Attached to Project: Rockbox
Opened by Ştefan Săftescu (SliMM) - Thursday, 12 April 2007, 21:51 GMT
Last edited by Thomas Martitz (kugel.) - Thursday, 16 January 2014, 15:49 GMT
Task Type Patches
Category Plugins
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Now, here is my first set of functions for semi-transparency. It was designed as a plugin lib. Since i don't know yet how to patch, i'll just upload each file. :)
This task depends upon

Closed by  Thomas Martitz (kugel.)
Thursday, 16 January 2014, 15:49 GMT
Reason for closing:  Out of Date
Comment by Ştefan Săftescu (SliMM) - Thursday, 12 April 2007, 22:04 GMT
Here's a patch :)
Comment by Hepdog (007quick) - Thursday, 12 April 2007, 22:09 GMT
Can you explain what this does for us not so smart people. Sounds exciting, but I have no clue.
Comment by Ştefan Săftescu (SliMM) - Thursday, 12 April 2007, 22:20 GMT
These are just simple functions for drawing semi-transparent rectangles, pixels and iamges with an alpha channel.. Io can read an article about alpha channels here: http://en.wikipedia.org/wiki/Alpha_channel
Semi-transparent rectangles are just unifor-coloured bitmaps with a uniform alpha channel.
Comment by Ştefan Săftescu (SliMM) - Saturday, 14 April 2007, 10:26 GMT
Here is an update (i've changed x2 and y2 to width and height)
Comment by Pascal Briehl (ColdSphinX) - Saturday, 14 April 2007, 18:37 GMT
you forgot to add france.320x240x16.bmp
Comment by Pascal Briehl (ColdSphinX) - Saturday, 14 April 2007, 18:45 GMT
also aunknown.c
Comment by Ştefan Săftescu (SliMM) - Sunday, 15 April 2007, 10:47 GMT
Sorry for that. I'll remove aunknown.c from the patch, as that is just another test file. I'm new to patching. france.320x240x16.bmp is now attached. It's a picture from google, since I didn't want to attach the original one.

Loading...