FS#7039 - MPEG playback crashes simulator

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Monday, 16 April 2007, 18:23 GMT
Last edited by Steve Bavin (pondlife) - Monday, 16 April 2007, 18:23 GMT
Task Type Bugs
Category Video
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


MPEGPlayer used to work in the simulator, but it now causes an immediate segmentation fault in video_thread() line 1359 - "curr_time = (info->display_picture->flags & PIC_FLAG_TAGS) ? ..."

The problem is that info->display_picture is NULL.

Tested using the H300 sim with Elephant's Dream.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Thursday, 19 April 2007, 19:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  Playback tested ok after properly updating the frame timer.
Comment by Michael Sevakis (MikeS) - Tuesday, 17 April 2007, 02:15 GMT
Well, that's not nice is it? ;) It probably is because display_picture is being accessed from where is is and the targets don't complain about the read on the first frame. We have to use display picture since that had the timestamps in the proper order. Before using current_picture had the stamps in GOP order. I'm working on updating the frame timing and dropping atm because of the correction so this shouldn't persist too long and I'll check the sim playback to be sure.