Rockbox

Tasklist

FS#7078 - Display a message if there is no playlist to view (fix for FS#7027)

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Tuesday, 24 April 2007, 20:51 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is a fix for the bug reported in  FS#7027 
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 26 April 2007, 08:21 GMT
Reason for closing:  Accepted
Comment by Alexander Levin (fml2) - Tuesday, 24 April 2007, 20:54 GMT
Ah, petur, I've just noticed your comment in the bug report. And you're probably right. So I'm not sure anymore that this patch fixes the problem! :-)
Comment by Alexander Levin (fml2) - Wednesday, 25 April 2007, 06:37 GMT
I still think that a message should be shown. The problem is that the check whether a list is present is wrong. It has false negatives, i.e. says that no list is available when there is one. This e.g. the case when the playback is paused. But if the list was played to the end then there is really no list to view. Resume playback will tell you "Nothing to resume." So the check must be somehow synchronized with the check in 'resume playback.'
Comment by Jonathan Gordon (jdgordon) - Wednesday, 25 April 2007, 11:45 GMT
I had a quick try getting the playlist viewer to load the playlist from the resume info, but for some reason it likes crashing... so its more than a quick fix :(
Comment by Alexander Levin (fml2) - Wednesday, 25 April 2007, 17:49 GMT
This seems to work as defined by petur: if resume playback is possible, you'll be able to view the playlist.
Comment by Jonathan Gordon (jdgordon) - Thursday, 26 April 2007, 00:05 GMT
that works? hmm... its bassically exactly what tried but it kept crashing the sim..

anyway, I dont think we need a new lang string for this, "No Playlists" is fine here imo.
Comment by Alexander Levin (fml2) - Thursday, 26 April 2007, 07:31 GMT
This worked for me at least. Other testers are welcome. And I think we need a specific message. "No Playlists" doesn't fit the context IMO.
Comment by Jonathan Gordon (jdgordon) - Thursday, 26 April 2007, 08:05 GMT
well, the reason I say we shouldnt add another string for this is because its not worth the added space imo.. "No Playlists" is close enough to near enough for this context to be fine. thats the only reason I havnt commited it yet.

Loading...