Rockbox

Tasklist

FS#7127 - Playback sometimes start in paused mode.

Attached to Project: Rockbox
Opened by Magnus Holmgren (learman) - Monday, 07 May 2007, 13:25 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sometimes when playing a track it will start in paused mode. A press on play makes it play.

To repeat:

* Play a directory to the end (starting at the last track and seeking towards the end to speed things up works fine).
* Start playing another directory.

The WPS will start, but playback will not, and the statusbar indicates playback is paused.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Saturday, 12 May 2007, 00:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  I\'m rather certain this is fixed now. I\'ve given several days for further reports.
Comment by Mike Miller (mikeage) - Tuesday, 08 May 2007, 14:28 GMT
Do you have "pause on headphone unplug" on? Are your headphones / speakers plugged in? There's an option there to disable playback on resume if headphones are disconnected...
Comment by Magnus Holmgren (learman) - Tuesday, 08 May 2007, 16:18 GMT
Nothing like that. I forgot to mention I noticed this on an H140, without such features.
Comment by Michael Sevakis (MikeS) - Tuesday, 08 May 2007, 16:37 GMT
Please test again with the latest build. Some other important fixes caused this but it should be ok now. Playback will track its playing/plaused/stopped states properly but I'm not sure in this behemoth if the playlist code relies on the old bugs. So test it out (read: abuse it) and hopefully this can be closed.

Loading...