FS#7175 - Crash ("Data abort at 0002F084) playing any fil

Attached to Project: Rockbox
Opened by Greg Ward (gward) - Tuesday, 15 May 2007, 23:44 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Rockbox is completely broken on my iPod Nano. It crashes playing any type of audio file: I've tried ogg, mp3, flac, and wav. Every time, the WPS screen shows briefly, to be replaced with

Data abort
at 0002F084

This is 100% consistent and reproducible. I first saw this in builds from mid-to-late March. Didn't try upgrading again until today, and a build from 20070515 shows exactly the same problem. (I've been successfully running a nightly build from 20070303 for a while now, so the bug was presumably introduced some time in March.)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 16 May 2007, 06:34 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Update your bootloader.

Please search out support channels before filing any tasks, this is a support issue and we provide absolutely no support in the tracker.
Comment by Will Robertson (aliask) - Wednesday, 16 May 2007, 03:06 GMT
Sounds like you might be using an old bootloader... try upgrading it and see if that helps.