Rockbox

Tasklist

FS#7187 - oddness with quitting via mpegplayer menu

Attached to Project: Rockbox
Opened by Philip Barton (audiophyl) - Saturday, 19 May 2007, 06:01 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my X5 I test two versions of Elephant's Dream (160x96 and 160x128) with the following settings:

Display FPS: Yes
Limit FPS: No
Skip Frames: Yes

If I quit playing a video by pressing the power switch up short then play the next video, everything works as expected. However, if I quit by entering the mpegplayer menu and selecting "Quit mpegplayer" then play the next video I experience the following:

No audio
Can't quit by using the power switch
Can't enter the mpegplayer menu (via the Record button on the X5)
FPS is through the roof (ramps up to something like 40 million FPS before displaying negative FPS)

When this happens, the video playback is *very* smooth, and I believe it's playing back at the correct framerate but displaying an incorrect framerate.

I must force quit by holding the power switch long three times in a row.

I have no other models to test this on, so I do not know if it is a problem limited to the iAudio X5.
This task depends upon

Closed by  Marcoen Hirschberg (marcoen)
Saturday, 19 May 2007, 19:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  it took us a while to figure out what was wrong, but the problem should be fixed in the latest builds
Comment by Paul Louden (Llorean) - Saturday, 19 May 2007, 16:25 GMT
Which SVN revision of Rockbox are you using?
Comment by Philip Barton (audiophyl) - Saturday, 19 May 2007, 18:45 GMT
Sorry for not including that!

I'm using the iAudio X5 nightly build from the 17th of May, 2007. I've never quit via the menu before, so I don't know if this bug/behavior exists in prior versions.

Loading...