Rockbox

Tasklist

FS#7194 - Report all flyspray issues here!

Attached to Project: Rockbox
Opened by Björn Stenberg (zagor) - Sunday, 20 May 2007, 11:12 GMT
Last edited by Björn Stenberg (zagor) - Thursday, 27 November 2008, 22:23 GMT
Task Type Bugs
Category Manual
Status Closed
Assigned To Björn Stenberg (zagor)
Operating System Another
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is a "meta bug" where we can collect all issues/bugs/problems with the new flyspray version.

Simply create a new comment for each issue. Try to include an url where the problem is visible.

I'll delete comments when they are fixed, keeping only unsolved issues listed.
This task depends upon

Closed by  Björn Stenberg (zagor)
Thursday, 27 November 2008, 22:23 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Closing this and opening #9584 for the new flyspray version.
Comment by Simon Menzel (Rincewind) - Sunday, 20 May 2007, 21:41 GMT
when I submitted a comment with a file attached to my entry #5555, I got these warnings:

Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965

Comment by judas_iscariote (judas_iscariote) - Monday, 21 May 2007, 02:37 GMT
> Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 965

your PHP mime_magic extension is broked,(flyspray just warns you that is happening) this warning is generated by PHP code mime_magic.c in function mconvert nothing to do with flyspray. this is likely to happend due to ine documented problem

"Note: This extension is not capable of handling the fully decorated magic file that generally comes with standard Linux distro's and is supposed to be used with recent versions of file command."

you can fix this:

1. unloading the mime_magic extension from PHP and installing the pecl.php.net/fileinfo extension if provided by your OS
2. I will add a call to the "shut up" operator to silence this warning when it shows.

I suggest you to upgrade to PHP5 if your OS provide it, latest version prefered.
Comment by Jonathan Mueller (JonathanMueller) - Thursday, 14 June 2007, 15:32 GMT
When adding a new bug, the severity select is empty, but "CriticalHighMediumLowVery Low" is printed next to it. I assume a problem with the HTML.
Comment by Nils Wallménius (nls) - Sunday, 17 June 2007, 08:58 GMT
I got this when trying to post a comment in  FS#7311 
The comment was added to the task ok.

Fatal error:
Uncaught Error of type [swift_connection_exception] with message [The SMTP connection is not alive and cannot be read from. (fsockopen: #) ]
@0 require_once() in /usr/share/flyspray/htdocs/index.php on line 150
@1 backend::add_comment() in /usr/share/flyspray/htdocs/includes/modify.inc.php on line 230
@2 notifications::create() in /usr/share/flyspray/htdocs/includes/class.backend.php on line 292
@3 notifications::sendemail() in /usr/share/flyspray/htdocs/includes/class.notify.php on line 41
@4 easyswift::easyswift() in /usr/share/flyspray/htdocs/includes/class.notify.php on line 237

in /usr/share/flyspray/htdocs/includes/external/swift-mailer/Swift/Errors.php on line 99
Comment by Nils Wallménius (nls) - Tuesday, 24 July 2007, 17:32 GMT
hmm, dependency graphs seems to be broken now.

WebDot Error:

Invalid graph source:
Syntax errors in file "file3 "
There may be more details in the WebDot server's error_log,
or check the graph file by running through dot (or neato or twopi or fdp or circo) locally.

see for example
http://www.rockbox.org/tracker/task/6574/depends
Comment by judas_iscariote (judas_iscariote) - Wednesday, 25 July 2007, 18:36 GMT
>hmm, dependency graphs seems to be broken now.

If you press the "prune" links above the dependency graph (as I did :D ) the graph is re-created and the problem is gone.


>Fatal error:
>Uncaught Error of type [swift_connection_exception] with message [The SMTP connection is not alive and cannot be read from. (fsockopen: #) ]
>@0 require_once() in /usr/share/flyspray/htdocs/index.php on line 150
>@1 backend::add_comment() in /usr/share/flyspray/htdocs/includes/modify.inc.php on line 230
> @2 notifications::create() in /usr/share/flyspray/htdocs/includes/class.backend.php on line 292
> @3 notifications::sendemail() in /usr/share/flyspray/htdocs/includes/class.notify.php on line 41
> @4 easyswift::easyswift() in /usr/share/flyspray/htdocs/includes/class.notify.php on line 237

flyspray no longer use this code, update to the latest stable version and try again.
Comment by Maurus Cuelenaere (mcuelenaere) - Saturday, 09 February 2008, 13:00 GMT
http://www.rockbox.org/tracker/toplevel/proj1

Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344

Only affects the 'Wikipedia' entry.
Comment by Barry Wardell (barrywardell) - Wednesday, 13 February 2008, 16:37 GMT
Just got this error when posting a comment to  FS#8562 . The comment still got posted OK though.

Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967 Warning: mime_magic: invalid type 0 in mconvert(). in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 967
Comment by Peter D. (PeterD) - Sunday, 27 April 2008, 14:33 GMT
Hi I get the following when I post a comment to bug. I am using Konqueror 3.5.7 on KDE 3.5.7


Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344 Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344 Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344 Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344 Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344
Comment by Peter D. (PeterD) - Sunday, 27 April 2008, 14:35 GMT
But not all the time.

It happened when I post to <http://www.rockbox.org/tracker/task/8889>, but not when I posted to this bug <http://www.rockbox.org/tracker/task/7194>.
Comment by Nils Wallménius (nls) - Tuesday, 13 May 2008, 06:38 GMT
Two new issues :)
1) http://www.rockbox.org/tracker/ gives a blank page, as does searching for "All task types" without a search string, which used to work.
this seems to have begun sometime last week, Bagder pointed to LinusN upgrading PHP...

2) Some user reported that registration is broken, didn't get any details but might be worth looking into...
Comment by Maurus Cuelenaere (mcuelenaere) - Sunday, 10 August 2008, 14:46 GMT
http://www.rockbox.org/tracker/index.php?events[]=1&events[]=13&events[]=2&events[]=3&events[]=14&events[]=29&events[]=4&events[]=5&events[]=6&events[]=7&events[]=8&events[]=11&events[]=9&events[]=10&events[]=17&events[]=18&events[]=30&events[]=31&fromdate=2001-08-28&todate=2008-08-01&event_number=-1&project=1&do=reports&submit=

If a developer goes to events and wants to view a lot of events (like 2001->2008; I know, it isn't a realistic scenario), it gives a blank page.
Perhaps PHP memory usage error?

edit:

tried again and got:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 35 bytes) in /usr/share/flyspray/htdocs/adodb/adodb.inc.php on line 2859

tried for the third time and got a blank page again :S
it seems to randomly goes blank..
Comment by Maurus Cuelenaere (mcuelenaere) - Tuesday, 26 August 2008, 14:41 GMT Comment by Henri Valta (cg) - Tuesday, 28 October 2008, 18:18 GMT
I see "Notice: Undefined index: 0 in /usr/share/flyspray/htdocs/includes/class.flyspray.php on line 344"

on http://www.rockbox.org/tracker/task/9509?pagenum=14

but ONLY when navigating to it from the patch list:
http://www.rockbox.org/tracker/index/proj1?type=4&pagenum=14

it does not happen when entering the url manually (without the pagenum part)
The task was originally listed under bugs but fixed as a patch, maybe it is related somehow

Loading...