Rockbox

Tasklist

FS#7205 - Clock plugin: freeze when trying to change the idle poweroff setting

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Wednesday, 23 May 2007, 15:04 GMT
Last edited by Peter D'Hoye (petur) - Monday, 25 June 2007, 22:29 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my H300 the clock plugin freezes when i try to change the setting "General Settings"=>"Idle Poweroff (temporary)" within the plugin. The player does not respond to buttons anymore and a hard reset is required.

Another thing i just noticed is, that the backlight setting in the clock plugin only takes effect after the plugin is restarted.

tested on a H300 with Version r13476-070523
This task depends upon

Closed by  Peter D'Hoye (petur)
Monday, 25 June 2007, 22:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  Do ask your parents a real name...
Comment by PaulJam (PaulJam) - Thursday, 24 May 2007, 09:23 GMT
It seems as this is caused by line 1476f in apps/plugins/clock.c :

rb->set_option("Idle Poweroff (temporary)", &idle_poweroff,
INT, idle_poweroff_text, 2, NULL);


if i change "INT" to "BOOL" it doesn't freeze anymore.
Comment by Peter D'Hoye (petur) - Monday, 25 June 2007, 22:29 GMT
looking at the code, it seems like having to restart the plugin is 'by design' so I'll leave that one alone for now

Loading...