Rockbox

Tasklist

FS#7207 - Prevent Sansa OF from refreshing database

Attached to Project: Rockbox
Opened by Alex (testdasi) - Wednesday, 23 May 2007, 20:52 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 01 November 2007, 14:01 GMT
Task Type Feature Requests
Category Settings
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It would be great if someone can make a feature (like a menu setting) to prevent the Sansa OF to refresh database. I tried to make one but my C knowledge is too little to make something that works.
This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)
Thursday, 01 November 2007, 14:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing all feature requests.
Comment by Jonathan Gordon (jdgordon) - Thursday, 24 May 2007, 09:12 GMT
The bootlooder shhuold do this..
if you have access to a linux box (or boot your computer with knoppix) connect the sansa then type "dd if=/dev/<your device> of=dump.bin" zip that up and put it online somewhere... we need to know what OF version you have to know how to stop it rebuilding....

<your device> is the 20mb partition on your sansa, and I think you ca get dd for windows...
Comment by Paul Seropian (nospaulatu) - Tuesday, 31 July 2007, 21:31 GMT
i get this problem too, and here's a dump of my firmware. i used bzip2 compression to get it to 2.4MB.
another annoying thing (i'm pretty sure this is caused by the OF refreshing the database) is that it recreates the file structure which includes files and directories i don't want, and also HIDES the music directory (!! why?)

http://www.mediafire.com/?5mzc0whjmtt

Loading...