Rockbox

Tasklist

FS#7241 - IMA ADPCM codec

Attached to Project: Rockbox
Opened by naftali (mirfle) - Thursday, 31 May 2007, 11:41 GMT
Task Type Feature Requests
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

this codec is a type of wav. it is used for voice recording on alot of cheap mp3 players, and is already supported by the ffmpeg project (http://ffmpeg.mplayerhq.hu/ffmpeg-doc.html#SEC25) so it should be easier to implement.
This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)

Reason for closing:  Fixed
Additional comments about closing:  Closing all feature requests.
Comment by Dave Chapman (linuxstb) - Thursday, 31 May 2007, 12:33 GMT
Do you have any example files you could make available? If possible, examples from different encoders.

From a quick look, ffmpeg appears to support no less than seven different IMA ADPCM codecs, and according to the "Sox" documentation, "IMA ADPCM is also called DVI ADPCM", which is already supported by Rockbox's wav codec.
Comment by naftali (mirfle) - Thursday, 31 May 2007, 13:37 GMT
I feel really silly. I got mixed up between a few different .wav files I have. the IMA ADPCM encoded files work fine. the problem is with the "microsoft ADPCM" and the "DSP Group TrueSpeech" encoded files. the good news is that they are also supported by ffmpeg.

example files:
DSP Group TrueSpeech:
http://fileho.com/download/fa5ab0411855/truespeech.wav.html
microsoft ADPCM
http://fileho.com/download/34eff089608/microsoft-ADPCM.WAV.html

Loading...