Rockbox

Tasklist

FS#7316 - H100 bootloader ver 7 pre-3 doesn't work with latest SVN (-os for coldfire)

Attached to Project: Rockbox
Opened by Alan Morse Davies (stuffedspacedog) - Saturday, 16 June 2007, 04:27 GMT
Last edited by Nils Wallménius (nls) - Tuesday, 19 June 2007, 20:41 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the commit of build with -os for coldfire targets, the H100 bootloader ver 7 pre-3 always comes up at power on if the firmware has been flashed. Using REC to set default is sticky, but when powering on again, the bootloader screen comes up again with a count down to powering down.

This happens every time, but is fixed when I revert to any version of Rockbox before the -os build commit.
This task depends upon

Closed by  Nils Wallménius (nls)
Tuesday, 19 June 2007, 20:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fix committed
Comment by Nathan (balliewnd) - Tuesday, 19 June 2007, 15:29 GMT
I have an iriver H-140 and I can confirm this happens on it as well using version v13631-070615. It seems like rockbox looses the default boot action that you set and will display the bootloader menu every time that the iriver is booted. The little [DEF] indicator of the default action is gone, and pressing record doesn't bring it back. If the reset button is pressed, then the indicator is revived and the bootloader sets the default correctly, but when the iriver is rebooted (by powering off and on like normal) it displays the bootloader menu again. I also noticed that after being in bootloader USB mode, the bootloader will load rockbox like it should. If you always boot from the disk anyway, but use the rom & ram images for crash recovery, this bug can be temporarily fixed as follows: Download a build of rockbox before the change (confirmed to work with the June 13, 2007 daily build, which is the daily right before the change) and just extract the rombox.iriver and rockbox.iriver to the root of your iriver. Then overwrite the flash images with those older ones with the iriver_flash plugin. Then reboot the player with the reset button to get the [DEF] indicator to appear again. This time when you set the default, it will stick and the bootloader will work like it should. The newer version of rockbox will boot correctly, and both the flash images will boot enough for recovery purposes, but won't play audio or run plugins (due to the different versions of the .rock and .codec files). This bug can be avoided altogether by not flashing rockbox images to your iriver, but the original firmware will take forever to load if rockbox crashes. Send me an email if you have urgent questions.
Comment by Nils Wallménius (nls) - Tuesday, 19 June 2007, 15:32 GMT
This seems related to  FS#7321  I posted a patch tere, could you test it?
Comment by Nathan (balliewnd) - Tuesday, 19 June 2007, 15:34 GMT
Correction - my previously listed fix doesn't work all the time. After you reboot from running the newer rockbox version, the bug rears its ugly head again. Seems the only way to fix this bug is to revert to a version of rockbox dated June 13, 2007 or earlier.
Comment by Robert Kukla (roolku) - Tuesday, 19 June 2007, 18:02 GMT
The fix from  FS#7321  seems to solve that problem as well.
Comment by Nathan (balliewnd) - Tuesday, 19 June 2007, 20:03 GMT
I have tested the  FS#7321  against the current svn build (rev 13673) on a real iriver h-140. After correcting for the last svn commit that broke the build (2007-06-19 09:54), this does solve the bootloader issue. Thanks nls! Attached is a patch to change rev 13673 to fix this issue and undo all the things the latest commit broke (effectively rev 13672 +  FS#7321 ).

Loading...