Rockbox

Tasklist

FS#7318 - Database: Playcount sometimes increases manually stopping playback

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Saturday, 16 June 2007, 12:20 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 15 April 2008, 12:39 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When you stop playback near the end of a playlist (when all remaining tracks are fully buffered?) then the playcount of the song that was playing increases. This leads to an incorrect Autoscore.

Reproduction: Initialize the database, enable "Gather Runtine Data", choose a WPS that shows playcount(%rp) and/or autoscore(%ra). set repeat to off. Then load the last track of a directory and stop playback after a while. If you now play the track again the playcount has increased by one.

I think the problem is that the decision whether the runtimedata is updated or not on a stop event depends on the variable "playlist_end" (see http://svn.rockbox.org/viewvc.cgi/trunk/apps/playback.c?r1=12975&r2=12976 ) and as far as i understand this variable becomes "true" as soon as all remaining tracks in the playlist are buffered.

H300 with r13634-070616.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 15 April 2008, 12:39 GMT
Reason for closing:  Fixed

Loading...