Rockbox

Tasklist

FS#7320 - USB AC charging problem

Attached to Project: Rockbox
Opened by Fed (Fed) - Sunday, 17 June 2007, 19:09 GMT
Last edited by Marc Guay (Marc_Guay) - Tuesday, 08 July 2008, 03:59 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

It seems that if I charge my sansa with an AC USB adaptor, rockbox sees a fast charge to 100%, and then stops charging. Then, when I remove the charger, even after an overnight charge, the battery level quickly drops to near where it was before I started charging it.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Tuesday, 08 July 2008, 03:59 GMT
Reason for closing:  Invalid
Additional comments about closing:  The charging isn't configured yet so this isn't a bug - simply an as-yet-implemented feature.
Comment by ziplock (ziplock) - Tuesday, 04 September 2007, 17:15 GMT
I will concur with this bug. The submitters description is accurate and the defect is reproducible. I understand the LOW priority, but is there any ETA? Thanks.
Comment by Linton Dawe (Linton) - Wednesday, 12 September 2007, 13:24 GMT
This is not only an AC adapter problem, it also occurs when connecting a switched on player running Rockbox to a PC. The OF is loaded when connecting to the PC with the player switched off, in which case charging goes fine. (Presumably you could boot the OF manually before connecting the AC adapter, if you need to use one?). Once a USB stack is available so that the OF is no longer required for file transfer, this bug will become a more serious annoyance.
Comment by Marc Guay (Marc_Guay) - Saturday, 03 November 2007, 18:25 GMT
From the e200 Wiki: USB handler ALERT! - The Sansa recognises when the USB has been plugged in, but does nothing more.

As far as I know charging isn't supported, hence, not a bug?
Comment by Marc Guay (Marc_Guay) - Wednesday, 05 December 2007, 20:21 GMT
Alrighty then, according to Paul Louden (http://forums.rockbox.org/index.php?topic=13812.msg104852#msg104852) the USB charging is supposed to be functional, so ignore my last comment, and change it to "I have the same bug, both with USB and AC charging."
Comment by Marc Guay (Marc_Guay) - Tuesday, 22 January 2008, 15:43 GMT
May require this patch to actually charge: http://www.rockbox.org/tracker/task/8363
Comment by Michael Carr (Strife89) - Wednesday, 23 January 2008, 01:37 GMT
This problem also seems to affect the c200 series. Does the patch work for those?

Loading...