Rockbox

Tasklist

FS#7381 - Disk activity makes down keypresses

Attached to Project: Rockbox
Opened by Kévin Ferrare (TiMiD) - Sunday, 01 July 2007, 02:28 GMT
Last edited by Björn Stenberg (zagor) - Thursday, 05 July 2007, 12:25 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

I just updated my rockbox build this morning (the last update I made was last week) and now when there is disk activity (loading songs for example) the player behaves as if the down key was pressed (in wps, the volume decreases until the disk stops working and in menus / file view, it scrolls down)

The problem doens't happens under the original firmware and with the previous build.
This task depends upon

Closed by  Björn Stenberg (zagor)
Thursday, 05 July 2007, 12:25 GMT
Reason for closing:  Fixed
Comment by smoofus (diachedelic) - Sunday, 01 July 2007, 03:54 GMT
I think my 5G iPod MAY have the same symptom - not sure. Since I updated to 070628 (a few days ago) and to 070630 (this morning) the interface works fine and then for no apparent reason (30 seconds in?) the scroll wheel freaks out and then the ipod crashes in a flash of white, and complains of low battery when restarting (although its full) with both Apple (when booted to Apple) and Rockbox lowbat screens. This never happened in 070627... Maybe its a hardware problem, but the apple firmware works fine (when not complaining of low battery).
Comment by smoofus (diachedelic) - Sunday, 01 July 2007, 04:55 GMT
Okay I rolled back to 070627...still having problems...can a cracked screen have ANY effect on the operating system? I realise that sounds stupid, but that's the only difference between when it worked and when it didn't.
Comment by Kévin Ferrare (TiMiD) - Tuesday, 03 July 2007, 01:07 GMT
I don't think your problem is related.
I reversed to a 070627 build and the problem disappeared
Comment by Steve Bavin (pondlife) - Tuesday, 03 July 2007, 08:48 GMT
Hi Kevin, can you check the daily builds and work out exactly which day this problem started? I don't have an H100 or I'd do it myself.
Comment by Kévin Ferrare (TiMiD) - Tuesday, 03 July 2007, 13:54 GMT
Hi Steve

I just checked, and the problem doesn't happens in the 06/29's build, only from the 06/30's one.
Looking at the 30's SVN activity, excepted commits for plugins there was one big commit to add support for the sd card in the sansa player, and one for the fonts.
I don't have that much time to look, but it seems that the SD card commit is somehow unrelated since all changes are between ifdef that shouldn't concern the iriver players.

I didn't looked very closely though.
Comment by Steve Bavin (pondlife) - Thursday, 05 July 2007, 08:01 GMT
Looking at the forum, it seems that this was fixed by Lear's commit on the 2nd. Please take the current build for a spin and report back.
Comment by Kévin Ferrare (TiMiD) - Thursday, 05 July 2007, 12:15 GMT
solved in the current builds

Loading...