Rockbox

Tasklist

FS#7383 - iPod Video freezes while copying files to PC

Attached to Project: Rockbox
Opened by ClausM (ccrider) - Sunday, 01 July 2007, 07:28 GMT
Last edited by Tom Ross (midgey34) - Monday, 30 July 2007, 22:12 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

iPod video 30gb freezes after some time of HD-action. (connected via usb-cable)

When trying to copy a large amount of (ogg)-files (10gb) from iPod to PC, then the iPod freezes after having copied about 2.6gb (~190 files)and any program you used for that action shows a read-error.
After resetting the iPod you can continue normally, until you have the next freeze again at about the next 2.5gb... same procedure, reset, continue copying, next freeze... and so on.
The AppleOS does NOT show this behaviour. You can copy this 10gb without any trouble.

Next issue of probably the same source:
I tried to make an iPod Image using TrueImage 10.0 which failed with error having rockbox-OS active. No problem with Apple-OS active.
This task depends upon

Closed by  Tom Ross (midgey34)
Monday, 30 July 2007, 22:12 GMT
Reason for closing:  Invalid
Additional comments about closing:  Rockbox doesn't have a USB mode on any iPods yet. When a USB cable is inserted, Rockbox resets and loads diskmode which is handled by Apple's firmware. If you are having issues with freezes in diskmode, Apple OS is to blame - Rockbox isn't even running.
Comment by Björn Stenberg (zagor) - Tuesday, 03 July 2007, 09:42 GMT
Pasting in the Request for Reopen comment by ClausM (ccrider):

Requested task to be re-opened - I think it MUST have something to do with rockbox-OS. The freeze ONLY happens when ROCKBOX is running ! The same action in Apple-OS does not cause the ipod to freeze. I switched between them about 20 times... and in rockbox the described action ALWAYS freezes the ipod, in aplle-os it NEVER freezes. In addition... I'm not quite sure about using apple usb-mode in rockbox. Why then do I just get half usb-speed in rockbox compared with usb action in apple-os ? (iPod -> PC)
Comment by Jens Arnold (amiconn) - Saturday, 07 July 2007, 17:24 GMT
This bug is definitely *not* rockbox related. During USB access rockbox isn't running, hence it cannot be the cause for the problem. Rockbox reboots into Apple disk mode when it detects an USB connection. It must do so because the iPods handle USB in software, and rockbox has no USB stack yet. So your problem is obviously that the diskmode rockbox can reboot into (the so-called emergency disk mode) has a bug. Nothing we can change... It's also known that emergency disk mode is slow on iPod Video and Nano.
Comment by Mark (Xebozone) - Saturday, 14 July 2007, 05:46 GMT
Yes, the the iPod resets itself when entering Disk Mode from Rockbox, thus, clearing any instance of rockbox from the ram, so it can't have anything to do with Rockbox. You may want to email/contact Apple about this, as it is their problem.

In the email, you must refer to "Disk Mode" as the mode that causes the freezing, not Rockbox. They are separate entities

Loading...