Rockbox

Tasklist

FS#7402 - Playback fails (data abort) after recording

Attached to Project: Rockbox
Opened by 42Bastian (42bs) - Thursday, 05 July 2007, 11:46 GMT
Last edited by Jens Arnold (amiconn) - Saturday, 13 September 2008, 20:44 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 4G Grayscale
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Starting replay directly after a recording ends in a data abort at 0x40001424.

Stacks: pcmrec is at 68% (IHMO ok), but dircache is 85% but might not
be related.
This task depends upon

Closed by  Jens Arnold (amiconn)
Saturday, 13 September 2008, 20:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r18490 for iPod 4th Gen, Color/Photo and Nano, and in r18509 for iPod Video.
Comment by Michael Sevakis (MikeS) - Thursday, 05 July 2007, 20:20 GMT
Not surprising given that the ASM FIQ handler depends on banked registers being left set but it uses a C FIQ handler for recording which fails to save r12. Fix as part of a PCM rework.
Comment by Steve Bavin (pondlife) - Thursday, 09 August 2007, 14:01 GMT
This sounds like a duplicate of  FS#7293  - although that's on a Nano.
Comment by Michael Sevakis (MikeS) - Sunday, 28 October 2007, 16:20 GMT
IIUC the data abort is gone now (not counting any nano troubles) but the PCM restart issue still remains. The reason is that the drivers actually turn the audio chip off by running the power down sequence when recording is disabled (which should set things back for playback) so that must be fixed before playback will work after recording.
Comment by Boris Gjenero (dreamlayers) - Wednesday, 02 April 2008, 05:15 GMT
With two different 5th generation (Video) iPods, after going into the recording screen, playback location doesn't move and there is no sound. There is no crash. Shutting down and restarting Rockbox makes playback work again.

Loading...