Rockbox

Tasklist

FS#7423 - Playlist insert doesn't work after skipping directory.

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Tuesday, 10 July 2007, 21:26 GMT
Last edited by Andree Buschmann (Buschel) - Wednesday, 27 July 2011, 18:55 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Release 3.5
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you use the buttoncombination to skip to the next directory (ON/PLAY + RIGHT), after that inserting songs to the playlist doesn't work correctly anymore. If you select a song and choose Playlist=>Insert from the contextmenu, the next track info in the WPS doesn't get updated and the disk doesn't spin up to rebuffer. The number of playlistitems in the WPS increases and the song appears in the playlistviewer. When the current song finishes the inserted song doesn't play and it plays the "old" playlist. At one point it repeats one song (propably the song that was playing while rebuffering). While the song is played the second time it shows the meta info from the next file for current and next song.

Tested with H300 version r13843-070710 (was also reproduceable in the uisimulator with default settings settings).


(JD edit: escalating to fix for the next release because this is an old bug and should be fixable)
This task depends upon

Closed by  Andree Buschmann (Buschel)
Wednesday, 27 July 2011, 18:55 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Works with r30210.
Comment by Steve Bavin (pondlife) - Monday, 30 July 2007, 12:17 GMT
Tested here, definitely broken.
Comment by Steve Bavin (pondlife) - Saturday, 09 February 2008, 15:29 GMT
FWIW, this is still a problem in r16249.
Comment by Jonathan Gordon (jdgordon) - Thursday, 04 December 2008, 07:16 GMT
no real surprise... this is still a problem with r19313.

any guesses where the problem might be? or how to go about finding it?

edit: slightly more info... this happens with a regular dirskip at the end of the playlist also
Comment by Jonathan Gordon (jdgordon) - Thursday, 04 December 2008, 08:39 GMT
I got it :D

Please test and let me know if any wierdness happens with the playlists because of this (a few of the changes are probably not needed, but can't hurt)
Comment by Steve Bavin (pondlife) - Friday, 05 December 2008, 07:52 GMT
Hi Jd,

I have a failure case:
1) From stopped, play the last track in a folder
2) Then select a previous track (no insert, just select)

The original track keeps playing (and it's metadata is shown), although the track number is correct for the selected track.
Comment by Steve Bavin (pondlife) - Friday, 27 November 2009, 11:00 GMT
I can no longer repro this, can you?
Comment by PaulJam (PaulJam) - Wednesday, 09 December 2009, 13:23 GMT
I can still reproduce it with r23905 on an H300 with default settings.
Comment by Jonathan Gordon (jdgordon) - Friday, 18 December 2009, 07:29 GMT
fix synced.. please test it out... the failure case doesnt repro for me (sim only though... whacking on my h300 now

edit: seems this fix might be broken...selecting a file from the browser to start a new playlist doesnt stop the current track playing

Loading...