Rockbox

Tasklist

FS#7430 - Recording level ranges are too 'wide'.

Attached to Project: Rockbox
Opened by Davide (Davide-NYC) - Saturday, 14 July 2007, 02:09 GMT
Last edited by Peter D'Hoye (petur) - Saturday, 14 July 2007, 15:50 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

According to my memory (and this wiki page http://www.rockbox.org/twiki/bin/view/Main/IriverRecording) the gain ranges for internal mic went from 0 dB to 30 dB and the line in gain range was from 0 dB to 28 dB.

Currently the internal mic gain range is 0 to 52.5 dB and the line in gain range is 0 dB to 48 dB. These gain ranges are not sane. :-)
This task depends upon

Closed by  Peter D'Hoye (petur)
Saturday, 14 July 2007, 15:50 GMT
Reason for closing:  Invalid
Additional comments about closing:  by design: analog and digital gain are combined. Feel free to request re-opening if I'm not correct ;)
Comment by Davide (Davide-NYC) - Saturday, 14 July 2007, 02:10 GMT
I forgot to mention FM Recording which has the same problem.
Comment by Michael Sevakis (MikeS) - Saturday, 14 July 2007, 13:43 GMT
Davide,

Hey. I missed you in IRC asking about this. I don't know when this problem cropped but it have been when some info in sound.c was moved to the audio driver. I've no idea other than that possiblity.
Comment by Peter D'Hoye (petur) - Saturday, 14 July 2007, 15:31 GMT
the uda has following ranges:
- analog, line-in: 0 - 24
- analog, int-mic: 0 - 30
- decimator: -63.5 - 24

which gives ranges:
line-in: -63.5 - 48
int-mic: -63.5 - 54

anything wrong with this (I'll now go and check the code against the above figures)

Loading...