Rockbox

Tasklist

FS#7440 - Remove (non-functional) hardware equalizer on iPod

Attached to Project: Rockbox
Opened by Dan Everton (safetydan) - Sunday, 15 July 2007, 11:08 GMT
Last edited by Dan Everton (safetydan) - Saturday, 24 November 2007, 07:58 GMT
Task Type Patches
Category Settings
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The attached patch removes the hardware equalizer menu from the iPod Video settings. It does keep the low-shelf and high-shelf filter settings but moves those to a bass and treble cutoff setting in the sound settings menu. Also, the bass and treble settings in the sound settings menu are replaced with the hardware eq equivalents.

Unfortunately I haven't tested this on target as I don't have an iPod Video to use.
This task depends upon

Closed by  Dan Everton (safetydan)
Saturday, 24 November 2007, 07:58 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed.
Comment by Dan Everton (safetydan) - Sunday, 15 July 2007, 11:23 GMT
Whoops. Didn't #ifdef a few things properly.
Comment by Dan Everton (safetydan) - Tuesday, 17 July 2007, 09:41 GMT
New version. Should actually let you set the treble and bass cutoffs.
Comment by Dan Everton (safetydan) - Tuesday, 17 July 2007, 11:06 GMT
New version. Disables the volume prescaler so volume doesn't go up when you up the bass/treble setting. Cutoff settings don't seem to work though.
Comment by Dan Everton (safetydan) - Wednesday, 18 July 2007, 09:20 GMT
Fix a warning. Correct the range of values for the cutoff setting. Only set the 0x100 flag on EQ1. Still no idea if the cutoff setting works or survives restarts.
Comment by Dan Everton (safetydan) - Sunday, 05 August 2007, 01:04 GMT
Synched.
Comment by Mark (Xebozone) - Saturday, 29 September 2007, 09:11 GMT
I don't know if I like this.

The hardware equalizer and the bass/treble settings produce different results!

The bass/treble settings on the sound menu does have bugs, but using the hardware equalizer clips the sound, making bass sound really fuzzy and crap!

And no, I'm not confusing this with the "software equalizer".

I prefer to use the bass/treble settings on the sound menu (even though the sound volume actually increases while using them) rather than linking them to the poorly designed hardware. unless there can be confirmation that the bad quality sound achieved using the hardware equalizer is not passed on to the settings in the 'bass/treble settings'.

If not, then I fully support this patch, as it possibly fixes the volume problem I filed on  FS#7427 
Comment by Thom Johansen (preglow) - Saturday, 29 September 2007, 11:41 GMT
Had a look at the driver code, and the bass and treble controls don't actually do anything (apart from the volume adjustment, which is a side-effect). Don't ask me why this hasn't been fixed before now, but with this patch it will at least be fixed. I don't really think this codec chip has any bass/treble controls apart from the HW EQ.
Any EQ will clip your sound if your volume isn't low enough, and this one is no exception. The SW EQ is actually worse at this unless you don't use the precut, at least the hardware EQ won't clip your sound unless you have the volume close to 0 dB.
Comment by Mark (Xebozone) - Saturday, 29 September 2007, 12:36 GMT
I knew that the sound will clip if it's too loud. I didn't know, however, that the current bass/treble settings did nothing but a volume increase! No wonder I didn't hear any clipping, hey :P ?

Someone should really finish this and commit it.

I would...but I don't have the time or experience
Comment by Thom Johansen (preglow) - Saturday, 29 September 2007, 12:38 GMT
And I don't have an Ipod Video. However, if no one seems to turn up today, I'll see if I can just cook up a patch and have someone test it.
Comment by Dan Everton (safetydan) - Thursday, 18 October 2007, 09:47 GMT
Basic resync of the patch. I'll work on getting the cutoff options being numeric rather than stings in a bit.
Comment by Dan Everton (safetydan) - Thursday, 18 October 2007, 10:32 GMT
Updated patch with numeric settings.
Comment by Dave Chapman (linuxstb) - Sunday, 28 October 2007, 22:27 GMT
I've finally got around to testing this.

Firstly, I'm aware that the cut-off frequencies quoted in the datasheet are unlikely to be accurate at different samplerates, but I don't like the use of "0", "1", "2" and "3". I'm sure we'll get lots of complaints/queries about that. But I also can't think of anything better...

There does seem to be a problem with the patch though - if I change the bass gain, then go to the bass cutoff screen and change the bass cutoff, then the bass gain is reset to 0. Going back to the bass gain shows the previous value selected, but it's no longer applied.

The same problem appears to happen with the treble.
Comment by Dan Everton (safetydan) - Monday, 29 October 2007, 09:28 GMT
The attached patch should fix the base/bass issue in the settings list and also change the cutoff settings values from 0..3 to 1..4. Still not great, but a little better.

I was unable to reproduce the issues with the gain resetting in the simulator.
Comment by Dan Everton (safetydan) - Wednesday, 31 October 2007, 10:10 GMT
Now with non-broken english.lang
Comment by Rubber Ducky (RD1945) - Friday, 23 November 2007, 07:58 GMT
Please resync. I'm getting an error on apps/settings_list.c
Comment by Dan Everton (safetydan) - Friday, 23 November 2007, 11:29 GMT
Back in sync with r15772.
Comment by Dan Everton (safetydan) - Saturday, 24 November 2007, 02:26 GMT
This version of the patch uses shadow registers. However I'm not certain I've got the mask values correct.
Comment by Dan Everton (safetydan) - Saturday, 24 November 2007, 05:58 GMT
This version should have correct mask values. I've verified that the bit patterns are correct for all values.

Loading...