Rockbox

Tasklist

FS#7564 - Buttons stops responding in delete confirmation screen

Attached to Project: Rockbox
Opened by Ib Hald Andersen (inhand) - Thursday, 09 August 2007, 10:58 GMT
Last edited by Peter D'Hoye (petur) - Sunday, 12 August 2007, 22:00 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to delete a directory or file using the
context menu the player freezes in the confirmation screen.

No buttons work, a hard reset is needed.

Rockbox revision: r14251
Bootloader version 7-pre3, flashed

Reproducible with a clean install and cleared settings
This task depends upon

Closed by  Peter D'Hoye (petur)
Sunday, 12 August 2007, 22:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  do check but I think it's fixed...
Comment by Peter D'Hoye (petur) - Thursday, 09 August 2007, 11:05 GMT
hmmm, I did this only yesterday on my h380, no problem. This was also with an SVN build...
Comment by Ib Hald Andersen (inhand) - Thursday, 09 August 2007, 11:18 GMT
I might add that I have run chkdsk /f on my H-140, and the
disk checks out ok.
Comment by Ib Hald Andersen (inhand) - Thursday, 09 August 2007, 23:01 GMT
Indeed it does not hang on my h-340, also tested OK on Ipod Color and Ipod Video.

However if you look at the screen while the delete is in progress, you will
see that the first line on the display contains garbage characters.

The last daily that works for me on the flashed H-140 is the August 5th daily.

Perhaps this is related to JdGordon's commit to adress FS #6310 (on Aug 5 10:25).


Comment by Paul Louden (Llorean) - Saturday, 11 August 2007, 00:03 GMT
With the official bootloader and an official build, not flashed, I have no problem on an H120.
Comment by Ib Hald Andersen (inhand) - Saturday, 11 August 2007, 16:40 GMT
Sure the crash is almost certainly caused by the player being flashed.

But what about the display corruption?

Check the progress screen (shown after you've confirmed the delete) top line,
on all builds since the Aug 5th daily (confirmed with latest r14284), that
line contains garbage (tested on h340, ipod photo and video).

I suspect this is caused by the same commit.
Comment by Peter D'Hoye (petur) - Sunday, 12 August 2007, 15:08 GMT
just seen the corruption on my h380.... So while it doesn't hang here, I changed the report to all targets
Comment by Peter D'Hoye (petur) - Sunday, 12 August 2007, 17:13 GMT
This is unrelated to the busy-bar as I also see it when deleting files. In the sim, the top string goes missing.
The bug must be in yesno.c - the yes/no screen code....
Comment by Peter D'Hoye (petur) - Sunday, 12 August 2007, 17:59 GMT
right... major weirdness going on...

in onplay.c starting line 524, if put twice the same struct in text_message, it works ok (string is shown).

in textarea.c starting line 47, I always see the correct string passing there, but passing it on to puts_scroll seems to go wrong

Right now my bet is on something wrong when dealing with multiple strings from LANG, but I have no idea atm
Comment by Peter D'Hoye (petur) - Sunday, 12 August 2007, 21:54 GMT
bingo... :)

Loading...