Rockbox

Tasklist

FS#7626 - fixing problem with "End of Song List" when viewing playlist without playback

Attached to Project: Rockbox
Opened by Xinlu Huang (polygonal) - Monday, 20 August 2007, 08:22 GMT
Last edited by Peter D'Hoye (petur) - Tuesday, 21 August 2007, 23:50 GMT
Task Type Patches
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently when you do contextmenu - playlist - view, the playlist will open but closes immediately if you are not playing anything (play/pause) with error/info message "End of Song List".

This turns out to be a bug in playlist_viewer.c, where a function that accepts an external filepath to open playlist checks for playing state, and if not playing/paused, exit and closes the playlist immediately.

I removed the part that checks for playing state since it's not actually needed except for one small later check.

This should fix  FS#7413 .

I tested it with my ipod 60GB, but no reason why it should not work on other targets as well. Comment below if you find anything wrong/no working as expected.
This task depends upon

Closed by  Peter D'Hoye (petur)
Tuesday, 21 August 2007, 23:50 GMT
Reason for closing:  Accepted
Comment by Dieter (dip) - Monday, 20 August 2007, 15:45 GMT
How do you access context menu - playlist - view if your are not in play or pause mode? On my iPod I can access this menu item only from the WPS screen which only available in play or pause mode. The context menu which can be accessed be pressing long SELECT on a file in the file browser or in the database view shows only the entries "playlist - insert" and "playlist - insert shuffled" when in stop modus but no "playlist - view" entry.
When I select the "playlist" menu from the main menu there is a menu entry "View Current Playlist" but this works.
Comment by Xinlu Huang (polygonal) - Monday, 20 August 2007, 15:48 GMT
Sorry, not clear enough. If you do context menu on a *playlist* in file browser, the problem occurs.
Comment by Xinlu Huang (polygonal) - Monday, 20 August 2007, 18:44 GMT
Fixed a small display bug. Now it should not display a now playing icon next to the last song in playlist if the playlist has finished playing.

Comment by Peter D'Hoye (petur) - Monday, 20 August 2007, 23:33 GMT
hmmm I created a playlist, used the context menu on it and viewed the playlist - while no music was playing.
iriver H10 and h300.
Comment by Xinlu Huang (polygonal) - Monday, 20 August 2007, 23:39 GMT
From file browser? i.e. do context-menu on .m3u or .m3u8 files? And playback state is stopped, not paused? Does not work for me... and the code, if I understand correctly, check for global resume state, and if stopped ( = -1 ) exit the while loop (thus the viewer screen) immediately and does not wait for any button to be pressed.
Comment by Peter D'Hoye (petur) - Tuesday, 21 August 2007, 23:30 GMT
ok, so this only happens if playback can't be resumes. Reproduced and confirmed
Comment by Peter D'Hoye (petur) - Tuesday, 21 August 2007, 23:45 GMT
patch looks likes it fixes it.
I'll need your full name to accept the patch

Loading...