Rockbox

Tasklist

FS#7709 - Add USB detection to Ipod bootloader

Attached to Project: Rockbox
Opened by Robert Keevil (obo) - Tuesday, 04 September 2007, 18:53 GMT
Last edited by Alex Parker (BigBambi) - Sunday, 06 June 2010, 00:06 GMT
Task Type Patches
Category Bootloader
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch adds detection of USB for Ipods whilst in the bootloader, rebooting into disk mode if USB is present. Only tested on a 5g, the GPIO checks for usb power on other targets may well be incorrect.
This task depends upon

Closed by  Alex Parker (BigBambi)
Sunday, 06 June 2010, 00:06 GMT
Reason for closing:  Out of Date
Comment by Dominik Riebeling (bluebrother) - Tuesday, 04 September 2007, 20:12 GMT
Just tried it on mini 2g, works fine. It's a bit surprising that the apple logo comes up twice (but I guess this is caused by the apple bootloader and nothing that could changed).
Comment by Robert Keevil (obo) - Tuesday, 04 September 2007, 20:25 GMT
Combining this with FS#6721 might be a way to get around that.
Comment by ricardo (richo_bicho) - Saturday, 22 December 2007, 07:56 GMT
what should I do with the file?
save as....what name?
which extension?
where do I save it?

thank you
Comment by Rosso Maltese (asettico) - Sunday, 02 March 2008, 12:04 GMT
The patch doesn't apply to the current build.
I started syncing it, but some source files are too much different so I can make some mistakes, as I never hacked RB firmware.
Could you do it, please?

Loading...