Rockbox

Tasklist

FS#7745 - Simulator leaks memory

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Monday, 10 September 2007, 12:57 GMT
Last edited by Steve Bavin (pondlife) - Monday, 10 September 2007, 13:47 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Running the Rockbox H300 simulator under Windows reveals that its memory usage (as shown in Task Manager) increases forever during playback. After half an album, my rockboxui.exe is using 22MB!
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 10 September 2007, 13:47 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  As amiconn pointed out, the allocation stops at the expected 32MB limit.
Comment by Steve Bavin (pondlife) - Monday, 10 September 2007, 13:11 GMT
OK, the problem might well be SDL.
- With the Cygwin-supplied SDL.DLL (no version info, dated 5th July 2007), memory usage starts at 2MB and increases.
- With the SDL.DLL 1.2.12 run-time from http://www.libsdl.org/download-1.2.php, memory usage remains roughly constant at 38MB (!)
Comment by Jonas Häggqvist (rasher) - Monday, 10 September 2007, 13:43 GMT
The DLL from libsdl.org is, if I'm not mistaken, compiled using mingw32 (at least I managed to build a bit-for-bit identical DLL using mingw32 on Linux). The DLL I provide with my prebuilt simulators show similar usage (ie. constant at around 38MB). So it's probably something to do with the cygwin SDL dll?

Loading...