Rockbox

Tasklist

FS#7785 - h10[20GB] hang-ups

Attached to Project: Rockbox
Opened by Nikkhil (AceNik) - Saturday, 15 September 2007, 13:01 GMT
Last edited by Dominik Riebeling (bluebrother) - Saturday, 20 October 2007, 15:17 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

guys the state of the h10[20GB] has been detoriating fromt he svn revsion number 145XX thats what i feel was the place from where it all started
symptoms are as follows:

1. Random hang-ups with no button or lcd response either while playing music or while booting up during the newer builds (svn 14707)

Cause: unknown

2. Resuming playback used to cause hang-up with the same case as above on svn 146XX

temporary solution: delete the playlist_control file on the device n then try playing something , would work then or after restart

3. Current till SVN 14708 , try opening a wps file with the text editor, player hangs, it also hangs randomly at any instant whether while booting or while playing music

PLEASE NOTE: in addition to these bugs there was a bug in between due to the id3.c file i guess, which caused the player to fail on database_init & give a random data abort his was fixed somewhere in between svn 146XX & error was in 1457X

i know this is a little random guys but i really wish it helps a little as i exactly cant point which build caused a problem, cause i've updated after a few intervals
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 20 October 2007, 15:17 GMT
Reason for closing:  Fixed
Comment by David Hall (Soap) - Saturday, 15 September 2007, 22:25 GMT
I will build you whatever revisions you need for testing if you are willing to do the testing regimen Llorean suggested in IRC.
Comment by Nikkhil (AceNik) - Saturday, 15 September 2007, 22:34 GMT
i can build them myself to, i know how to compile & patch builds myself which i always do, & yes i do double check my bugs before posting them here with the normal builds too, the only thing im not sure of is the revision numbers where this started from, all i can say is an approximate, cause thats when i updated my builds
Comment by Barry Wardell (barrywardell) - Sunday, 16 September 2007, 19:13 GMT
Revision 14707 doesn't sound like it would be the cause of trouble. It would be bery helpful if you could isolate the exact revisions where the problems started. Since you can compile, it's just a matter of checking out different revisions (using 'svn update -r #####' where ##### is the revision number), then compiling it and testing on your H10. That way, we could determine exactly which revision is where the problem started.
Comment by Nikkhil (AceNik) - Sunday, 16 September 2007, 23:00 GMT
ok guys ive been compiling & trying out builds rearding the bug where a .wps or a .txt file is "open-with" "text-editor" the player crashes so the svn revision that causes this is 14487, from this revision number onwards till date every other build has this problem, i hope you experts can verify this now.
on 14487 just try opening a .wps or .txt with text editor player freezes needs reset
builds till svn 14486 work perfect on the h10[20GB]

im also trying to figure out hard where the freeze occurs int he playback from will keep you posted.
Comment by Przemysław Hołubowski (p.h.) - Monday, 17 September 2007, 18:54 GMT
Look at  FS#7730 . Problems seems to be introduced in rev. 14590.
Comment by Alex Vanderpol (karashata) - Saturday, 20 October 2007, 01:22 GMT
I think this task can probably be closed now, the recent builds haven't been acting up like some of the older builds had a while back.
Comment by Nikkhil (AceNik) - Saturday, 20 October 2007, 14:55 GMT
yes, i agree this task can be closed now

Loading...