Rockbox

Tasklist

FS#7806 - Current sansapatcher's bootloader fails to boot OF

Attached to Project: Rockbox
Opened by Sander Sweers (infirit) - Thursday, 20 September 2007, 19:10 GMT
Last edited by Barry Wardell (barrywardell) - Friday, 12 October 2007, 09:22 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The current sansapatcher install a bootloader that fails to start the original firmware. It loads rockbox fine.

I used the older version 0.2 of the sansapatcher and this did work.

Forum thread: http://tinyurl.com/3yo4wu
This task depends upon

Closed by  Barry Wardell (barrywardell)
Friday, 12 October 2007, 09:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  A new version of sansapatcher (0.5) and a new bootloader (3.0) has been released.
Comment by Sander Sweers (infirit) - Saturday, 22 September 2007, 16:00 GMT
Found the commit that broke the bootloader. Not sure how it could have but that is up to the devs to find out ;-)
----
Rev: 14654
Firmware "hacker" code for the e200r install so the full bootloader rom doesnt need to be written.
Requires a custom version of e200tool which isnt available yet.

* Causes the complete lockup of the sansa e200. Before it would just reboot.

Rev: 14424

 FS#7634 : Add support for high capacity microSD cards (SDHC). We now support SD specification Version 2.00 which covers cards up to 32GB in size.

* breaks the bootloader. It just reboots trying to load the OF.
Comment by Dave Chapman (linuxstb) - Tuesday, 25 September 2007, 09:33 GMT
This may be an obvious question, but I can't recall anyone answering it - do the people who are having problems booting the OF have a microSD inserted in their player?
Comment by Simon Menzel (Rincewind) - Friday, 28 September 2007, 18:01 GMT
@linuxstb: I don't have a microSD and just got the problem with the sansapatcher v0.3.
Comment by Barry Wardell (barrywardell) - Saturday, 29 September 2007, 10:10 GMT
So it's the SDHC support that's breaking the bootloader loading the OF. I'm not having this problem on my own Sansa (in fact, the bootloader freezes with a microSDHC inserted without the new code) so it's hard for me to test.

Can someone please try commenting out the SDHC detection on lines 596-598 and see if that improves things?
Comment by Sander Sweers (infirit) - Wednesday, 03 October 2007, 00:07 GMT
Although I am watching and reporter of this bug no e-mail has reached me :-( So please ping me if you need me to test a patch.

To answer linuxstb: No, standard 2gig microsd

barrywardell: It just reboots instead of locking
Comment by Michael Sevakis (MikeS) - Thursday, 04 October 2007, 16:35 GMT
Here's a bootloader for e200 that has absolutely no hotswap support at all. See if this does something good.

To install:
sansapatcher -a PP5022.mi4

EDIT: here the diff for it as well just to have the changes logged.
Comment by Sander Sweers (infirit) - Thursday, 04 October 2007, 17:04 GMT
I used the diff and can confirm it boots the OF again.
Comment by Stanislav Borutsky (cax) - Thursday, 04 October 2007, 20:24 GMT
After recovering with original fw PP5022.mi4 via recovery mode
and sansapatcher -a PP5022.mi4 (with the attached 58K PP5022.mi4) everything works.
Now I wish to have a reverse bootloader.
Comment by Michael Sevakis (MikeS) - Thursday, 04 October 2007, 21:50 GMT
Stanislav,

1) You may file a feature request for this or customize the rockbox one and submit a patch. It's just a keypress treatment issue.
2) A reverse bootloader wouldn't have helped here if that's what you're implying.
Comment by Ben Mendis (sitwon) - Friday, 05 October 2007, 09:01 GMT
@barrywardell: I checked out the most recent code and commented out the section labeled "Check for SDHC" and built a bootloader. The resulting pp5022.mi4 works fine.
BTW: I'm testing on an affected e200R unit, not e200. Not sure if they both suffer from the same problem or different problems with the same symptoms.
Comment by Barry Wardell (barrywardell) - Friday, 05 October 2007, 09:29 GMT
OK, so it sounds like somehow the Sansa isn't ignoring CMD8 (the check for SDHC) like it should, and that's what's causing the problems for some people.

The problem is that before adding the SDHC stuff, on my own Sansa the Rockbox bootloader would freeze whenever there was a SDHC card inserted, so I don't think removing the troublesome line is a good solution.

MikeS' solution sounds like the best way to do things provided we still don't get a freeze in the bootloader when a SDHC is inserted any more. I should be able to test that myself this evening if nobody else gets there first.
Comment by Michael Sevakis (MikeS) - Friday, 05 October 2007, 15:11 GMT
No ata thread either
Comment by Michael Sevakis (MikeS) - Monday, 08 October 2007, 20:40 GMT
I committed the first patch (I hope that _was_ the right one :P). I guess this doesn't close until sansapatcher is fixed and maybe that nop weirdness.
Comment by Barry Wardell (barrywardell) - Wednesday, 10 October 2007, 09:49 GMT
So, is booting the OF working OK now after that commit? If so then I'll release a new sansapatcher with the updated bootloader.
Comment by Ben Mendis (sitwon) - Friday, 12 October 2007, 04:31 GMT
I tested today on my brother's e200R that has been experiencing this issue. The bootloader from trunk (with MikeS's commit) works great. Looks to me like the problem is solved.

Loading...