Rockbox

Tasklist

FS#7842 - Songs were played in the wrong order

Attached to Project: Rockbox
Opened by Dirk Schemionek (DirkS) - Thursday, 27 September 2007, 10:09 GMT
Last edited by Steve Bavin (pondlife) - Thursday, 27 September 2007, 15:25 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While playing songs (mp3) from a large (176 tracks) list of songs, after title No. 10 the title No. 100 was played instead of No. 011. All tracknumbers were stored with leadings zeros (e.g. 001, 002, 010 and so on) in a ID3V2 tag. The error occurs only while songs were played form the Database. Playing them from the filemenu works fine.
Rockbox version r14835M-070923
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 27 September 2007, 15:25 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Support issue. Go to the forum or IRC if further input is needed.
Comment by Dominik Riebeling (bluebrother) - Thursday, 27 September 2007, 11:02 GMT
Does the database show the files in the correct order? How's the order in the playlist?

I bet this is a problem related to the fact that the database per default uses 2-digits track numbers only.
Comment by Dominik Riebeling (bluebrother) - Thursday, 27 September 2007, 11:04 GMT
ah, and overlooked that fact: why aren't you using an official build? The version string clearly shows that it's modified.
Comment by Dirk Schemionek (DirkS) - Thursday, 27 September 2007, 11:20 GMT
The Database shows the files in the wrong order, no.100 after no.010 and the order in the playlist is as wrong as it is played.
I use a modified version (kugel.s build) because it comes with many patches, themes and icon-sets.
But i recognized this error with an official build before.
Comment by Xinlu Huang (polygonal) - Thursday, 27 September 2007, 13:59 GMT
It's not a bug... If it does not show up in the right order in database, that is because your database (by default) use 2-digit track number, as bluebrother points out. You can modify this behavior to using 3 digit tracknum instead by using custom tagnavi file - do a search in twiki for custom tagnavi file.
Comment by Dirk Schemionek (DirkS) - Thursday, 27 September 2007, 14:06 GMT
Thank your very much, i will do the search.

Loading...