Rockbox

Tasklist

FS#7940 - Party mode hangs with blank playlists

Attached to Project: Rockbox
Opened by Nick Dyer (njd27) - Friday, 12 October 2007, 13:07 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 19 August 2008, 11:56 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Procedure to reproduce:

1. Rename .rockbox directory
2. Install fresh build + fonts (although this bug was present in the previous build I tried from 6 month or so ago as well).
3. Boot up
4. Go to settings and turn on party mode
5. Queue a song (GUI says "Queue last")
6. Resume playback says "Nothing to resume" which I guess is fair enough
7. Playlists: View Current Playlist freezes solid

Occasionally I have been able to get it as far as viewing the current playlist and seeing a list of songs: then when I click Navi on the first song it freezes there.

If I fiddle around and play some stuff and create some playlists before turning on party mode then everything works fine. It seems to be the combination of party mode and not really having played anything before that triggers the hang.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 19 August 2008, 11:56 GMT
Reason for closing:  Fixed

Loading...