Rockbox

Tasklist

FS#7966 - Incorrect menu captions in playback control menu (always 'Yes')

Attached to Project: Rockbox
Opened by Bertrik Sikken (bertrik) - Monday, 15 October 2007, 19:41 GMT
Last edited by Nils Wallménius (nls) - Saturday, 20 October 2007, 21:56 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Setup:
* Sansa e260 with r15122

How to reproduce:
* Start a game plugin that has an 'Audio Playback' menu, e.g. sokoban or solitaire.
* Enter the Audio Playback menu and select either 'Change Volume', 'Enable/disable shuffle' or 'Change repeat mode': menu caption of sub-menu is always 'Yes'.

Analysis:
* the last argument in all function api->option_screen callbacks (title) is NULL.
* 'Yes' is the text for language id 0.
This task depends upon

Closed by  Nils Wallménius (nls)
Saturday, 20 October 2007, 21:56 GMT
Reason for closing:  Accepted
Comment by Bertrik Sikken (bertrik) - Monday, 15 October 2007, 20:32 GMT
Here's a simple patch that fixes it. It doesn't do internationalisation though, I get compile errors when I try to #include lang.h
Comment by Bertrik Sikken (bertrik) - Wednesday, 17 October 2007, 17:30 GMT
It turns out that plugins don't support internationalisation (yet), so I think using literal strings is a valid way to solve the problem.

Loading...