Rockbox

Tasklist

FS#7999 - resume playback start screen - sansa doesnt react

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Saturday, 20 October 2007, 15:23 GMT
Last edited by Michael Sevakis (MikeS) - Sunday, 21 October 2007, 13:13 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I have set the start screen to resume playback, and I start the player, the player doesn't react for like 10 seconds. It plays music fine, it just kinda freezes for this 10 seconds.

This is also when I don't have resume playback set, but spam the play(up) button at the boot, so that he instantly goes to wps.

There are no problems, when I don't have resume playback set, and don't go to the wps instantly after boot.

Tested with the current build as of r15222 with the latest bootloader (r15222), but I've noticed that a few revisions too. I think it started with the multicore commit on oct 16th (r15134).
This task depends upon

Closed by  Michael Sevakis (MikeS)
Sunday, 21 October 2007, 13:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Caused by omitting a call to reenable interrupts when thawing a thread.
Comment by Thomas Martitz (kugel.) - Saturday, 20 October 2007, 15:36 GMT
The problem remains when I use the official bootloader build-in sansapatcher.
Comment by Thomas Martitz (kugel.) - Saturday, 20 October 2007, 16:30 GMT
Ok, I could determine that the multicore commit is causing that. I tried r15133 without having this issue. Then I updated to r15134 which has this issue.

Loading...