Rockbox

Tasklist

FS#8000 - tagnavi problem

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Saturday, 20 October 2007, 19:01 GMT
Last edited by Robert Kukla (roolku) - Friday, 30 November 2007, 11:24 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've noticed a bug with the tagnavi.

When I try to use a tagnavi_custom.config, as recommended in tagnavi.config, the player freezes at the bootlogo. The only thing one can do then, is the hard-shutdown (holding power for 15 sec).

This happens even if the tagnavi_custom.config is just a copy of tagnavi.config with another filename.

When I edit tagnavi.config itself, then there is no problem.

Tested with r15224.
This task depends upon

Closed by  Robert Kukla (roolku)
Friday, 30 November 2007, 11:24 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Warning added to wiki.
Comment by Nils Wallménius (nls) - Saturday, 20 October 2007, 23:10 GMT
if tagnavi_custom.config is a copy of tagnavi.config make sure it doesn't include either itself or tagnavi.config to avoid funky endless loops.
Comment by Thomas Martitz (kugel.) - Saturday, 20 October 2007, 23:50 GMT
Ah, I see. Thanks for your help.

I think it should be mentioned somewhere, that the user should avoid the include thing. I think this is likely to happen to one.
Comment by Xinlu Huang (polygonal) - Sunday, 21 October 2007, 01:01 GMT
I wrote a little patch somewhere in flyspray (don't remember the number) that ends parsing tagnavi file as soon as a root menu is found. That could probably solve this problem.
Comment by Robert Kukla (roolku) - Friday, 30 November 2007, 11:22 GMT
"end parsing tagnavi file as soon as a root menu is found" won't fix it as the parser will never reach that point.

Loading...