Rockbox

Tasklist

FS#8025 - scrolling freezes when you scroll as a new screen is loading

Attached to Project: Rockbox
Opened by George Nychis (gnychis) - Thursday, 25 October 2007, 21:45 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 13 December 2009, 20:24 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Whenever the screen is at something like "searching..." and you move your finger on the scroll wheel, whether its accidentally or due to impatience, the scroller will not work when the new screen is loaded until you press a button such as forward or back. The pressed button will *not* cause an action, such as going back in the database if the rew button is pressed; it will only re-initialize the scrolling feature again.

Example:
*press FWD* -> causes "searching..." screen
*move finger around scroll wheel*
*new screen loads*
*move finger around scroll wheel* -> nothing happens, scroller is disabled
*press REW* -> nothing appears to happen
*move finger around scroll wheel* -> scrolling now works
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 13 December 2009, 20:24 GMT
Reason for closing:  Out of Date
Additional comments about closing:  no response from reporter, plus it might be a duplicate (see comments).
Comment by Marc Guay (Marc_Guay) - Friday, 12 December 2008, 15:48 GMT
e200 & r19391 - Could not reproduce using the database initializing and updating splash screens.
Comment by Johannes Linke (Jaykay) - Wednesday, 17 December 2008, 17:22 GMT
couldnt reproduce it either. e200 + 19466
Comment by George Nychis (gnychis) - Wednesday, 17 December 2008, 18:48 GMT
Hi, I am the OP. I have not tried with the newest build, let me give it a try now before this is posted resolved.
Comment by George Nychis (gnychis) - Wednesday, 17 December 2008, 19:04 GMT
I've installed the newest version but my database needs to rebuild, will post ASAP
Comment by George Nychis (gnychis) - Wednesday, 17 December 2008, 20:05 GMT
still happens on my iPod video 80gb Gen 5.5. If I click on database, then artist, and while it says "Searching..." i accidently (but purposely in this case) hit the scroll wheel, the cursor will not move when its done searching until i click forward or backward.
Comment by Dominik Riebeling (bluebrother) - Sunday, 06 December 2009, 17:23 GMT
is this still an issue? There hasn't been any report for almost a year now.
Comment by Johannes Linke (Jaykay) - Sunday, 06 December 2009, 17:29 GMT
apparently this is the same as FS#7332, so i suggest closing this one here.

Loading...