Rockbox

Tasklist

FS#8030 - Use of TIMEOUT_NOBLOCK locks the simulator

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Friday, 26 October 2007, 13:21 GMT
Last edited by Steve Bavin (pondlife) - Friday, 26 October 2007, 18:04 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After entering the database debugging screen, the simulator locks hard (with the screen displayed).

This is caused by the use of TIMEOUT_NOBLOCK in dbg_tagcache_info().

Using
info.timeout = 1;
fixes this.

However, it would be better if someone could fix up the threading on the simulator so that TIMEOUT_NOBLOCK works like it does on the target, so I won't change this.
This task depends upon

Closed by  Steve Bavin (pondlife)
Friday, 26 October 2007, 18:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be sorted now.

Loading...