Rockbox

Tasklist

FS#8074 - Playback of flac files stops on Sansa e250 after some time

Attached to Project: Rockbox
Opened by Jan (dumbo20) - Friday, 02 November 2007, 20:39 GMT
Last edited by Brandon Low (lostlogic) - Monday, 05 November 2007, 03:12 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Playback of some FLAC files stops reproduceable on Sansa e250 after some time (e.g. between 1 and 3 minutes).

The files that cause the stop and the time (for the particular file) when playback stops is always the same.
After such a stop it is not possible to continue playback of this file, only skipping to the next file is possible.

Tried this on a fresh install of r15410-071102 wihout any changes in config. As music I tried "Pictures" from Katie Melua. Tracks 2, 4 and 6 cause the stop.
This task depends upon

Closed by  Brandon Low (lostlogic)
Monday, 05 November 2007, 03:12 GMT
Reason for closing:  Fixed
Comment by Brandon Low (lostlogic) - Saturday, 03 November 2007, 13:24 GMT
Can you please try the latest build and see if this is improved?
Comment by Jan (dumbo20) - Saturday, 03 November 2007, 14:41 GMT
Same with r15433M-071103
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 04 November 2007, 21:48 GMT
and now?
Comment by Marc Guay (Marc_Guay) - Sunday, 04 November 2007, 22:00 GMT
Same problem in the same song at the same spot for me, except this time I lost button/wheel control and had to hard shutdown. r15463.
Comment by Marc Guay (Marc_Guay) - Sunday, 04 November 2007, 23:00 GMT
Just tried again and did not lose button/wheel control. Could just have been some stupidy on my part with the new keypad.
Comment by Marc Guay (Marc_Guay) - Monday, 05 November 2007, 00:40 GMT
I tested a bunch of different files (WAV, FLAC and MP3) and wrote down the details about each of them and looked for similarities between those that froze the playback and it looks to me like files which are over 29mb crap out at around that point.

- 59mb WAV which is 5:43 stopped at 2:45
- 33mb FLAC which is 5:12 stopped at 4:25
- 38mb FLAC which is 5:40 stopped at 4:27
- 41mb FLAC which is 5:34 stopped at 3:40

Using this theory I predict that a 71mb MP3 which is 30:33 should stop around 12 minutes... And the survey says... (Presently at 7:50)

- 71mb MP3 which is 30:33 stopped at 12:21!

Oh and the thing which freezes up all menu/wheel control is Stop after the file has frozen (which I've never done before but hit accidently now that it's where menu used to be).

Hope this helps.



Comment by Brandon Low (lostlogic) - Monday, 05 November 2007, 02:22 GMT
that does help... the buffer is not shrinking-and-then-filling on these large files correctly. I think I know the code path and will try to fix it soon.
Comment by Brandon Low (lostlogic) - Monday, 05 November 2007, 03:12 GMT
I just committed a patch that should fix this. It works for me (tm) on a 32m flac.

Loading...