Rockbox

Tasklist

FS#8082 - no/unreliable display of run-time data tags in WPS

Attached to Project: Rockbox
Opened by Robert Kukla (roolku) - Saturday, 03 November 2007, 19:37 GMT
Last edited by Robert Kukla (roolku) - Sunday, 04 November 2007, 21:17 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am afraid I have another MoB bug: The display of run-time data tags such as rating and playcount in the wps is unreliable. I have identified the following situations (gigabeat, r15436):

- select from tree/database while nothing is playing -> no display
- select from tree/database while a track is playing -> display
- skipping forward -> sometimes display (I *think* it coincides with buffering)
- skipping backward -> display
- fast forward skipping (i.e. track not yet buffered) -> display

I have also noticed when forward skipping it sometimes briefly displays invalid info before it is overwritten by the correct one.
This task depends upon

Closed by  Robert Kukla (roolku)
Sunday, 04 November 2007, 21:17 GMT
Reason for closing:  Fixed
Comment by Brandon Low (lostlogic) - Sunday, 04 November 2007, 06:17 GMT
Isn't this a dupe of 8040?
Comment by Robert Kukla (roolku) - Sunday, 04 November 2007, 08:46 GMT
No.  FS#8040  is about the gathering of the data (the on-unbuffer callback) - this is about the display of already gathered data (the on-buffer callback).
Comment by Robert Kukla (roolku) - Sunday, 04 November 2007, 17:44 GMT
Okay, the populating of the runtime data fields in the mp3entry struct is done via callbacks from playback.c/pcm.c. AFAIK this is a result of the apps/firmware division and the fact that firmware code can't call apps code directly (which would be required for HWCODEC, as pcm.c is in firmware)

However it would be much more intuitive (and KISS) if the runtime data fields were filled like any other fields in the mp3entry struct during the call to get_metadata() thereby avoiding any inconsistencies as they are happening now.

The patch implements this mechanism and fixes so the  FS#8082  bug.

For symmetry it would be nice to use the same mechanism for HWCODEC (I believe HWCODEC doesn't use get_metadata()), but I'll leave that to someone with an actual device.
Comment by Robert Kukla (roolku) - Sunday, 04 November 2007, 17:57 GMT
move position of function call to after the setting of the path to make it work for formats other than mp3.

Loading...