Rockbox

Tasklist

FS#8149 - scrolling breaks conditionals

Attached to Project: Rockbox
Opened by Magnus Lindström (mlind) - Tuesday, 13 November 2007, 15:53 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Sunday, 18 November 2007, 13:47 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have conditionals to show TAG info on PLAY, and FILE info on PAUSE.
But the scrolling tag breaks the conditional.

This works (simplified for clarity):
%?mp<|%ac%ia|%al/%d2||>

But this does not:
%s%?mp<|%ac%ia|%al/%d2||>

It keeps the TAG info on PAUSE,
unless I skip song during PAUSE - gives me FILE info
THEN if I press PLAY the FILE info stays until I skip.

Asked on the forum almost a year ago but never wrote a report until now.
http://forums.rockbox.org/index.php?topic=2484.msg16960#msg16960

Tried today with r15604-071112
iRiver H120
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Sunday, 18 November 2007, 13:47 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#7006 
Comment by Nicolas Pennequin (nicolas_p) - Wednesday, 14 November 2007, 09:55 GMT
This looks like a duplicate of  FS#7006  to me... I'll try to confirm before closing though.
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 18 November 2007, 13:46 GMT
Yes, definitely is a dupe of  FS#7006 . The problem is that dynamic tags aren't compatible with scrolling lines. You have to choose, or use two identical sublines to force a refresh every now and then.

Loading...