Rockbox

Tasklist

FS#8296 - Buffer underruns when playing FLAC files

Attached to Project: Rockbox
Opened by Darren Carter (darren) - Tuesday, 11 December 2007, 01:39 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Monday, 14 January 2008, 22:58 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To Nicolas Pennequin (nicolas_p)
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've traced the problem in every rev back to rev 15832. Playback is interupted for 1-2 sec while it tries to catchup the buffer, and then plays for a second or two and repeats. Problem did not occur during MP3, or M4U playback, only FLAC. Problem is not noticed in previous rev 15806. By the looks of the changelog, there was quite a bit of activity in buffer related code in rev 15832, just seems odd why it only affected FLAC. Testing performed on a 4G iPod Photo.
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Monday, 14 January 2008, 22:58 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See  FS#8260 
Comment by B.Walter (MuziekMeester) - Sunday, 23 December 2007, 15:24 GMT
Same problem here on a H140, though I don't know exactly what rev-nr. it started with.
mp3s are just fine, FLAC causes skipping and meanwhile continuos HD-activity, leaving the buttons unresponsive. It may eventually stop after 2-5 minutes.
( FS#8324  probably adresses the same problem)
Comment by Anton Romanov (theli) - Thursday, 10 January 2008, 09:17 GMT
same here, iPod Mini 2G
Comment by Anton Romanov (theli) - Thursday, 10 January 2008, 10:05 GMT
however, if i pause on first track in playlist ... wait until pcm buffer fills and disk reads stop i can listen to the whole playlists without skips
Comment by Nicolas Pennequin (nicolas_p) - Thursday, 10 January 2008, 11:32 GMT
Your last comment leads me to believe that this is definitely the same problem as  FS#8260 .

Loading...