Rockbox

Tasklist

FS#8319 - Battery % Does not update

Attached to Project: Rockbox
Opened by Nate Rowe (Spanky) - Friday, 14 December 2007, 05:31 GMT
Last edited by Dominik Riebeling (bluebrother) - Saturday, 20 September 2008, 22:55 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a 1200mah battery and I have it set that way in rockbox. I will plug it into a wall charger and rockbox will stay on/running (maybe another bug?) and I will come back even up to 5 hours later and the % of the battery hasn't changed. I can restart the iPod and it will update the %.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 20 September 2008, 22:55 GMT
Reason for closing:  Out of Date
Additional comments about closing:  closed upon request
Comment by Jonathan Gordon (jdgordon) - Sunday, 11 May 2008, 09:48 GMT
is this still an issue?
Comment by Nate Rowe (Spanky) - Tuesday, 20 May 2008, 18:01 GMT
No, there is a problem with charging. I have a ac charger and last night rockbox said I had about 39 minutes left on it, and I drained it down to about 24. I plugged in the charger and went to sleep, about a half hour later (I'm guessing 24 minutes) I hear a beep and its my IPL starting and loading rockbox. I figured out that while rockbox was running, it was not allowing the battery to charge so it would die, but since the charger was attached it would start up and load rockbox the die and repeat. So I loaded apple firmware and it charged completely overnight without problem. Now it's plugged into the charger and the battery is draining.

I am using build 17488.
Comment by Yoshihisa Uchida (Uchida) - Friday, 23 May 2008, 04:38 GMT
This bug still occurs for svn 17611.

For firmware/powermgmt.c (In the function power_thread_sleep()),
when the battery was larger than 8% and does not charging,
the voltage of the battery and the remainder capacity of battery.

I send this bug's patch.
For iPod Color/Video, it was confirmed that this problem had solved.
Comment by Yoshihisa Uchida (Uchida) - Friday, 23 May 2008, 06:16 GMT
I send the above patch(fs8319.patch) applied the Rockbox firmware (for iPod color/photo).

After original Rockbox binary (r17611) install in your iPod color/photo,
replace new firmware.
Comment by Nate Rowe (Spanky) - Friday, 23 May 2008, 06:20 GMT
Alright. I am downloading 17611 right now. I will copy over the rockbox.ipod and report back how the battery and charging works. Thanks for your work.
Comment by Nate Rowe (Spanky) - Friday, 23 May 2008, 06:56 GMT
Everything looks ok so far, except when I plug the ipod into the wall charger, the hard drive spins up. Weird, and kinda funny at the same time. Hope this helps.
Comment by Yoshihisa Uchida (Uchida) - Saturday, 24 May 2008, 15:07 GMT
Check the new firmware, thank you.

The above problem is different from the original problem.
In the item of the debug menu, there was something without the processing
when connecting it with the charger.

I send new patches.

1.fs8319_2.patch
For fs8319.patch, a little corrected.
- fimware/powermgmt.c
It was corrected that the capacity of the battery was correctly calculated
      when Rockbox connected it with the USB cable (not charger).

2.fs8319_3.patch
The above problem's patch.
- apps/debug_menu.c
When Rockbox connects USB or a charger,
it was corrected that this machine was charged.


And I send the Rockbox firmware which apply 2 patchs.(for iPod color/photo).

After original Rockbox binary (r17622) install in your iPod color/photo,
replace new firmware.
Comment by Nate Rowe (Spanky) - Tuesday, 27 May 2008, 06:47 GMT
I do intend to reply to this, I installed the patches on my ipod, I just need to get some time to report back on how they work. Thanks for your work Uchida.
Comment by Nate Rowe (Spanky) - Monday, 02 June 2008, 03:23 GMT
Again, running 17622 with your patch and it appears to work great but the hard drive still turns on when I plug it in.
Comment by Nate Rowe (Spanky) - Monday, 02 June 2008, 06:13 GMT
It also seems to be charging slow, it's been plugged in for about 4 hours now and it's only charged to 20%. I plugged it in when it had 3% left.
Comment by Nate Rowe (Spanky) - Monday, 02 June 2008, 08:45 GMT
Another weird thing that I meant to mention earlier is the % and estimated time. When the charger is unplugged, it will read "2h 58m (36%)" and then I will plug the charger in and it will change to "5h 26m (7%)". What does the info mean when the charger is plugged in? Thanks.
Comment by Yoshihisa Uchida (Uchida) - Sunday, 08 June 2008, 07:10 GMT
I'm sorry that the answer is late.

Thank you for confirming the operation of the Rockbox that I corrected.

The problem that changed into the value that the percent of the battery is small was
corrected in the much more if charging the iPod.

I send the new firmware (base on svn 17703).
(The patch file see http://www.rockbox.org/tracker/9072.)

Please, could you advise to be happened when what operation is done though the hard disk still turned while charging it?
Comment by Nate Rowe (Spanky) - Wednesday, 25 June 2008, 21:46 GMT
Hey there, sorry for the waaayyyy late response. Things have gotten real busy. I tried the 17703 and it doesn't appear to be charging at all now, it MIGHT have charged 1% or so in the last hour and a half but it's certainly a lot slower than disk mode. Also the hard drive spins up when I plug it in to the AC. The percents and time left looks all accurate. Thanks for your work.
Comment by Yoshihisa Uchida (Uchida) - Sunday, 29 June 2008, 09:19 GMT
Thank you for having it checked that the percent of a battery will seemingly be right also during charge.

While Rockbox moving, when it charges, because electric power consumption is many, it is almost not charged.
It is very difficult to gather charge speed.

Comment by Nate Rowe (Spanky) - Sunday, 29 June 2008, 20:06 GMT
So everything's good? I don't see how Rockbox could be using all the power that the AC adapter provides but at least it doesn't lose power and it's easily charged while in disk mode. Thanks for all your help Uchida.
Comment by Yoshihisa Uchida (Uchida) - Sunday, 27 July 2008, 14:54 GMT
The comment has very slowed, sorry.

For the problem that USB connection is not recognized,
the problem had still remained in the before correction.
I send new Rockbox firmware and credits.rock plugin. (base svn. 18127)

Please, copy rockbox.ipod onto the .rockbox and credits.rock onto the .rockbox/rocks/viewers.

change from new_ipod_color_fw_3
 In the following cases, it was corrected that USB connection might not be recognized.
 - system: view Rockbox Version
 - debug: View PCF registers
  - debug: View HW info
  - debug: View I/O ports
Comment by Nate Rowe (Spanky) - Sunday, 27 July 2008, 20:53 GMT
Thank you for the patch. USB works great now, rockbox sees the USB connection and restarts into disk mode, when I unplug the USB it reboots into rockbox. Unfortunately I don't know when it happened but when I plug my AC charger in while rockbox is running, it doesn't appear to charge. However, I tested this for only a few minutes and my battery is pretty much full. I will have to drain it and do an all day charge/test and report back.
Comment by Nate Rowe (Spanky) - Saturday, 20 September 2008, 22:35 GMT
This can be closed. It appears to no longer be an issue with the current build.

Loading...