Rockbox

Tasklist

FS#8341 - rename of scroll buttons

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Monday, 17 December 2007, 22:49 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 10 January 2008, 08:08 GMT
Task Type Patches
Category Build environment
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch renames all BUTTON_SCROLL_UP, _DOWN, _BACK and _FWD to BUTTON_SCROLL_CLOCK and _COUNTER for Sansa e200 and iPod (not H10).

This simplifies the usage of those buttons and increases the consistens between those targets.

This fixes also the issue where scrolling on the e200 in pictureflow (and other plugins using PLA) led to move cursor/items/w.e. in the wrong direction.

Tested successfully on the e200.

I need someone to test it on the iPods. It worked on the iPods sim, though a test on the real targets would be appreciate.

BTW: I've noticed that the background images of the iPods for the sim are wrongly labeled, it shows 2 for scrolling counter-clockwise, but it scrolls clockwise (meaning scrolling down in lists), and 8 as scrolling clockwise respectevly. This happens in the current build as well.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 10 January 2008, 08:08 GMT
Reason for closing:  Accepted
Additional comments about closing:  ta
Comment by Jonathan Gordon (jdgordon) - Tuesday, 18 December 2007, 03:14 GMT
I agree with the idea of the patch, but is there a better word than CLOCK and COUNTER?
Comment by Dan Everton (safetydan) - Tuesday, 18 December 2007, 03:38 GMT
ROL and ROR (rotate left and rotate right) are the only things I can think of. Unless you want to start using words like widdershins...
Comment by Steve Bavin (pondlife) - Tuesday, 18 December 2007, 07:17 GMT
/me lols... BUTTON_TURNWISE....
Comment by Thomas Martitz (kugel.) - Tuesday, 18 December 2007, 10:27 GMT
I talked about that with Llorean and Nico_P, and the consesus was CLOCK and COUNTER. I can imagine several descriptive names (i.e. CW/CCW) right now, any is better than UP/DOWN and FWD/BACK.
Comment by Jonas Häggqvist (rasher) - Tuesday, 18 December 2007, 10:32 GMT
I thought about CW and CCW too, but those are probably way too typo-friendly.
Comment by Thomas Martitz (kugel.) - Tuesday, 18 December 2007, 17:45 GMT
New version with a few bug fixes.

This version is tested on an iPod 5.5G, so there should be no issues left anymore.

*fixed wrong scrolling direction on iPod in blackjack
*fixed wrong scrolling direction for e200 and iPod rockblox
*worked around an issue in metronome. It's using PLA, which isn't suitable for volume changes. I #ifdef'd scrollwheel targets out. This issue is also present in the current build.

Note: I think CLOCK and COUNTER are the best in terms of descriptiveness and typo-friendlyness. But if you want other names, you just need to do search&replace in this patch.
I think, if you like the idea of this patch, I think it can be committed now.
Comment by Dave Chapman (linuxstb) - Tuesday, 18 December 2007, 18:37 GMT
What's the problem keeping with FWD and BACK? IMO, they are nice (i.e short and descriptive) names for the two wheel events and I can't recall anyone ever questioning which directions they refer to.

I never noticed that the Sansa port invented new (SCROLL_UP and SCROLL_DOWN) names for wheel invents, instead of using the existing FWD/BACK, and I agree that they should be changed - but they could just be changed to FWD/BACK.

Maybe it's a US vs British English thing, but I would use "anti-clockwise", not "counter-clockwise", so just seeing the word "COUNTER" doesn't immediately make me think of turning a wheel backwards. If there is a desire to stop using FWD/BACK, then I would vote for CW/CCW, rather than CLOCK/COUNTER, as the former is the usual way I have seen them abbreviated - but the lack of a nice abbreviation is why I prefer the names FWD/BACK...
Comment by Thomas Martitz (kugel.) - Tuesday, 18 December 2007, 19:14 GMT
I'm not disliking FWD and BACK, however, I think clockwise and counter-clockweise is way more descriptive. It's dependant on how you look at the wheel. Looking at the bottom point of the wheel gives the FWD/BACK still a different meaning than looking at the top point. Than lo CW/CCW is way too typo-friendly imo, as rasher allready mentioned.

When we discussed in IRC about this, Llorean and others mentioned they dislike FWD/BACk as it is not more descriptive than UP/DOWN. The general consensus was to use CLOCK and COUNTER.
Comment by Steve Bavin (pondlife) - Tuesday, 18 December 2007, 19:19 GMT
COUNTER seems particularly unintuitive to me, probably because the phrase is "anti-clockwise" this side of the pond. (It makes me think of a timer/counter for some reason...)

I much prefer FWD/BACK - I think it's generally obvious that FWD = clockwise, BACK=anti-clockwise (or counter-... if you must).

You can turn a (clock) dial forward or backward, but not up or down, right?
Comment by Thomas Martitz (kugel.) - Tuesday, 18 December 2007, 19:21 GMT
As I said, FWD and BACK is IMO still dependant on how you look at the wheel.
Comment by Steve Bavin (pondlife) - Tuesday, 18 December 2007, 19:23 GMT
Sorry, can you explain a little more? How could BACK mean clockwise?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 18 December 2007, 23:20 GMT
I also think CW/CCW is much better than FWD/BACK. It is unambiguous. Perhaps CWISE/CCWISE?
Comment by Thomas Martitz (kugel.) - Tuesday, 18 December 2007, 23:30 GMT
I think those are too typo-friendly.
My actual idea is to go for CLOCK and ANTICLOCK, how about that?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 18 December 2007, 23:57 GMT
OK with me.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 19 December 2007, 00:15 GMT
how about BUTTON_CLOCKWISE, BUTTON_ANTICLOCKWISE? dropping the SCROLL makes it slightly shorter and more intuitive than just _CLOCK.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 19 December 2007, 07:59 GMT
Way to go Jonathan! Gets my vote.
Comment by Thomas Martitz (kugel.) - Sunday, 23 December 2007, 00:36 GMT
So guys, did you get any enlightements regarding the naming? IMO dropping the scroll isn't good.
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 23 December 2007, 12:51 GMT
Why is dropping the SCROLL_ bad? Isn't the touchwheel used for other things than scrolling?
Comment by Thomas Martitz (kugel.) - Sunday, 23 December 2007, 14:21 GMT
I didn't say bad! I just thought that it doesn't indicate the scrolling enough, and that BUTTON_CLOCKWISE sounds a bit weird. However, CLOCKWISE idincates scrolling itselfs pretty good.

How about we drop the BUTTON? SCROLL_CLOCKWISE anyone? :)
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 23 December 2007, 15:18 GMT
All buttons are prefixed with BUTTON_, we don't want to change that.
Comment by Thomas Martitz (kugel.) - Sunday, 23 December 2007, 15:21 GMT
It was rather meant as a joke anyway.
Comment by Thomas Martitz (kugel.) - Wednesday, 09 January 2008, 01:20 GMT
Uploading a new version.

a) sync'd to recent svn

b) reenabled scroll wheel support for e200 in brickmania (was possible removed by accident)
c) made both e200 and ipod consistent in mpeg_settings.c (some changes to other buttons as well!)
c) scroll wheel support in midiplay for e200

d) changed names to BUTTON_CLOCKWISE and BUTTON_ANTICLOCKWISE, as jdgordon suggested.

Please note: I didn't make changes to the manual code (yet).

Loading...