Rockbox

Tasklist

FS#8347 - PictureFlow TrackListing bug

Attached to Project: Rockbox
Opened by Sam Bouwer (sammienator) - Tuesday, 18 December 2007, 20:40 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 24 June 2008, 10:19 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It's hard to explain this 'bug' in PictureFlow, so here some pictures:

First screendump:
Tracklisting, everything normal

Second screendump:
Scrolled down, also everything normal

Third screendump:
Than I pressed Menu, and than Select again (to open Tracklisting of the same album)

I'm using an iPod Nano 1G with build 15954
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 24 June 2008, 10:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  about to ci a fix
Comment by Sam Bouwer (sammienator) - Tuesday, 18 December 2007, 20:45 GMT
Here are the screendump...
Comment by Marc Guay (Marc_Guay) - Thursday, 24 January 2008, 20:57 GMT
Not exactly sure what the problem is here... No blue selection bar? I just tried to recreate this on a Sansa e200 and couldn't.
Comment by Sam Bouwer (sammienator) - Friday, 25 January 2008, 06:55 GMT
I've updated my nano, but its still the same...
This is what I do:
1. scroll to an album with more songs in it than fit on the screen (so you have to scroll in tracklisting-view)
2. press SELECT to go to tracklisting
3. scroll down to the latest song
4. press MENU (or something like that on your player...) to view the album art
5. press SELECT again to go to tracklisting

Now the scrollbar is at the first song, but I still see the latest song, just like step 3
Maybe this is only for the iPod Nano...
Comment by Marc Guay (Marc_Guay) - Friday, 25 January 2008, 13:18 GMT
Okay, I get it now, and can reproduce. r16150. Also note that the selection bar can't be brought back from it's disappearance by going back to the album cover and then returning to the list. Only by entering the track list of a different album or exiting the plugin seems to reset it.

Loading...