Rockbox

Tasklist

FS#8386 - Problem when fast forwarding and then quickly changing track

Attached to Project: Rockbox
Opened by Kankkis (Kankkis) - Sunday, 30 December 2007, 01:20 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 20 September 2009, 11:59 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Nicolas Pennequin (nicolas_p)
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just installed Rockbox to an 80GB iPod (5.5 gen)

I noticed a small bug when I was fast forwarding a track; if you fast forward and shortly afterwards change the track to the next one, the new track doesn't play. In other words push and keep pushing the "next" button, release and press it again, Rockbox changes the song, but doesn't play it.

Pressing play/pause doesn't do anything, neither does changing the track (the track changes, but doesn't play)

Only when you fast forward a few seconds, playback starts again.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 20 September 2009, 11:59 GMT
Reason for closing:  Out of Date
Additional comments about closing:  I don't have this problems on my flash and HD targets. Please open a new bug report if it's still present.
Comment by Nicolas Pennequin (nicolas_p) - Tuesday, 08 January 2008, 22:32 GMT
Is this issue still present in the current code?
Comment by Kankkis (Kankkis) - Wednesday, 09 January 2008, 13:10 GMT
Updated today, and the bug is still present.
Comment by Harold Van (hsvsunshyn) - Sunday, 27 January 2008, 06:19 GMT
If this is the same problem I am having, stopping (by holding down play/pause for a couple of seconds) and then pressing play also gets playback to start.

(I also have a 5.5G 80GB.)

Most of the time, skipping single tracks (instead of skipping a number of tracks within a few seconds) does not seem to cause a problem. I believe that there may be a correlation between skipping tracks and the buffer, since it seems to be when it has to hit the hard drive that the problem occurs. (This may also be a red herring; I may not be remembering the circumstances.)

I will try to pay closer attention in the future. In the meantime, is there a WPS tag (such as a buffer % full meter or something) that could help me troubleshoot this problem?
Comment by Kankkis (Kankkis) - Sunday, 27 January 2008, 16:44 GMT
The problem you explained is not the same one (or at least I think so), although I've had that problem as well. Skipping multiple tracks very fast (probably to the end of the buffer) also stops playback, but it's not really the same bug. You should start a new thread with that problem, if you can't find one already started.

I just noticed, thanks to Harold Van's comment, that if the next song isn't in the buffer, fast forwarding and changing the track doesn't necessarily freeze playback. Only if the next song is buffered, playback freezes until you fast forward again.
Comment by Marc Guay (Marc_Guay) - Friday, 07 March 2008, 23:00 GMT
Cannot reproduce on the Sansa e200 w/ r16543.
Comment by Nicolas Pennequin (nicolas_p) - Friday, 04 April 2008, 17:47 GMT
I can't reproduce either (r16956 on iPod 5.5G 80G).
Comment by Kankkis (Kankkis) - Tuesday, 08 April 2008, 11:24 GMT
Still happens to me with r17027. The next song has to be in the buffer for it to happen, playback won't be affected if the track is being read from the hard disk (not from RAM as it would when it's buffered). If you still can't reproduce the bug it might be my settings, and I've attached a config-file based on them.

I just did a clean install of Rockbox, rebuilt all of the databases and so on (but I did change some settings before trying to reproduce the bug). I'll do another clean install without changing any settings and try to reproduce. :)
Comment by Michael Lahey (mlahey) - Friday, 11 April 2008, 00:54 GMT
I'm getting this bug on my Ipod 4G greyscale and thought I would add what I have found. I am using r16???
Each of these things seem to always cause playback failure:
1)skipping forward or backward rapidly.
2)seeking forward and then immediately skipping forward
3)Seeking backward for a while and then immediately skipping backwards twice(to get to the previous track).
4)skipping forward or backward as soon as you start playback. i.e. select "resume playback" and press skip as soon as you get into wps

pressing skip after an unpause does not cause this problem

After any of these things happens the disk spins up and the playback stops. The interface continues working though. You can skip forward or backward. The tag data for the new file is shown in the WPS. you can exit to the main menu and add files to the playlist, etc. you can pause and unpause. The play and pause icons are displayed properly in the WPS. Everything seems to work, except the track never actually starts playing. The player remains completely quiet (even keyclicks stop playing) The time for the track always stays at 0:00 in WPS. I know of three ways to exit this state(thanks to previous posts!).
1) restart the player
2) start seeking forward (seeking backwards does not work, but we are already at 0:00)
3) stop the track by holding down play (which causes a keyclick) and then resume playback.



While experimenting with this bug I found another similar problem (possibly should be a different bug).

If you are seeking forward and then simultaneously press skip backward or are seeking backwards and then simultaneously press skip forward the player goes into a semi-frozen state. At this point almost nothing on the UI works. the playback stops. The play, seek forward or seek backward icon s stuck on the WPS. you cannot skip forward or backwards you cannot exit to the main menu or bring up the context menu. holding down play in this state causes the player to crash. the "Shutting down" box shows up and disappears. then "*PANIC* Event not found" is printed on top of WPS and the player hard crashes.

seeking forward and then immediately skipping backwards or seeking backwards and then immediately skipping forwards causes a similar error. In this case the user interface mostly freezes. Either the seek forward or seek backwards icon remains on the screen. You cannot skip songs or exit to the main menu. the backlight still turns on and off automatically.
Comment by Michael Lahey (mlahey) - Friday, 11 April 2008, 01:09 GMT
oops. posted my last post a bit too soon. ignore that last paragraph please. also, I am using r16989.

you can exit the semi-frozen state(i.e. seek forward and simultaneous press skip back) by seeking either direction. I could not reproduce the "*PANIC* Event not found" hard crash again.

I found a forth way to enter the silent state. seeking backwards and then pressing skip forwards immediately afterward(but not simultaneously) causes the silent bug. Seeking forward and then skipping backwards does not seem to cause the silent bug.
Comment by Kankkis (Kankkis) - Wednesday, 30 April 2008, 00:13 GMT
Well, my iPod seems to have broken. Actually it did this about two weeks ago. I've formatted the hard drive and tried everything to make it functional but nothing seems to work. There's no warranty left, so I'm not exactly sure if I'll get it fixed or buy a new one. If I buy a new one it'll probably be an iPod classic, which isn't supported as of yet, so I can't test this bug any more (or use Rockbox D:). If I get it fixed I'll be posting here if the bug is still present. I'll post here in a couple of weeks about which of the above I'll be doing.
Comment by Kankkis (Kankkis) - Wednesday, 30 April 2008, 00:15 GMT
Oh, and I couldn't reproduce the bug with the regular settings, so this bug has something to do with a particular setting. (see above for my cfg-file)
Comment by Steve Bavin (pondlife) - Wednesday, 30 April 2008, 06:53 GMT
Michael - Please ensure you're using a current build and let us know if that helps.
If not, your config.cfg might be useful.
Hmm, I wonder if "rewind duration on pause: 5" is particularly relevant?
Also, what music format(s) are you using?

Comment by Kankkis (Kankkis) - Wednesday, 30 April 2008, 07:44 GMT
The last build I was using before my iPod broke was r17027. The rewind duration might be causing the bug, since unplugging the headphones and putting them back in is the only thing that restarts the playback (apart from changing songs completely). All of my music is in mp3 format.
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 20 July 2008, 22:34 GMT
Has someone managed to reproduce this? In recent versions?
Comment by UltraMagnus001 (ultramagnus0001) - Sunday, 31 August 2008, 15:33 GMT
I have the same problem on r18366-080831. My iPod freezes when skipping quickly through tracks and most times there's an annoying high pitch sound. Holding the fast forward down in most cases fixes the problem , until I want to skip again. I have an iPod 30 gig 5.5. I think it has something to do with the equalizer, crossfading or buffer. I will experiment and try to get more information.
Comment by UltraMagnus001 (ultramagnus0001) - Sunday, 31 August 2008, 15:41 GMT
PS I forgot to attach my config file. I'm also attaching my eq settings, don't know if it helps.
Comment by Nathan Myers (ncm) - Tuesday, 30 September 2008, 23:39 GMT
I wonder if this is related to #8836. UltraMagnus001's 08-31 07:33 comment makes it sound similar, except according to the config.cfg, he doesn't have keyclick turned on.
Comment by UltraMagnus001 (ultramagnus0001) - Sunday, 05 October 2008, 02:13 GMT
I had Key Click turned on initially, after turning it off the problem decreased, but didn't go away. It seems when there's more memory or information being process there's more of a chance for the error. e.g If I use a theme with the peak levels, crossfade and eqs with high Q settings
Comment by Jonas Häggqvist (rasher) - Thursday, 11 December 2008, 03:39 GMT
Does this still happen with current SVN?  FS#8836  is possibly fixed according to http://www.rockbox.org/tracker/task/8836#comment27005 so please try reproducing with a fresh version.
Comment by UltraMagnus001 (ultramagnus0001) - Sunday, 14 December 2008, 01:09 GMT
Problem seems to be fixed with "r19413" date 20081213 installed. I will comment back if problem comes back. Thanks!
Comment by Steve Bavin (pondlife) - Monday, 15 December 2008, 08:59 GMT
Michael, Kankkis - how are current builds working for you?
Comment by Scott Armitage (Aikon-) - Thursday, 08 January 2009, 15:31 GMT
I had this problem on my iPod Video 30GiB, however just today I upgraded to Rockbox 3.1 and the problem seems to be fixed.
Comment by Thomas Martitz (kugel.) - Monday, 15 June 2009, 22:58 GMT
Can anyone reproduce it still?

Loading...