Rockbox

Tasklist

FS#8429 - iPod 5g (60GB) continual disk scanning

Attached to Project: Rockbox
Opened by Aden (amey01) - Monday, 07 January 2008, 23:52 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Friday, 25 January 2008, 23:09 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

iPod 60GB 5g continual disk scanning.
ALAC files
Equaliser LS filter only in use.

The disk scans for extended periods of time when playing music. Sometimes the disk will scan continually.

Pressing "PAUSE" will allow the disk to switch off until the buffer runs out. When the disk turns on to refill the buffer it will take a minimum of 45 seconds but will sometimes scan continually until "PAUSE" or "STOP" is pressed.
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Friday, 25 January 2008, 23:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See  FS#8397 
2008-03-13: A request to re-open the task has been made. Reason for request: No - it is not the same. The iPod is responsive and there are no hardware issues. It just appears that it is unable to fill the buffer. Serious because the battery is depleted very quickly.
Comment by Giles (gilesn) - Wednesday, 09 January 2008, 13:30 GMT
Getting similar behaviour for iPod 60GB 5g playing ALAC resulting in ~1s breaks in playback
Comment by Giles (gilesn) - Wednesday, 09 January 2008, 13:32 GMT
noticed this in r16027 and previous builds in Dec 2007
Comment by Joel Wiegman (jwiegman) - Monday, 14 January 2008, 14:26 GMT
I see the same thing on my iPod 5.5G 80GB (FLAC and MP3). Seems to be associated with playlist files for some reason? When I play songs individually or in a directory the scanning does not occur. But when I play a .m3u8 file (or resume one), the scanning goes on for several minutes each time. I've tried varying a lot of settings, including database auto-update and directory cache, and nothing seems to do the trick.
Comment by Joel Wiegman (jwiegman) - Monday, 14 January 2008, 14:37 GMT
FYI, this bug is a duplicate of  FS#8397 ...

Loading...