Rockbox

Tasklist

FS#8442 - Additional disk spinups with "Gather Runtime Data"

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Thursday, 10 January 2008, 16:31 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 18 February 2008, 06:38 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When the database option "Gather Runtime Data" is enabled then there is sometimes an additional disk spinup at track transitions. The additional spinup happens at the next trackchange after rebufering happened.

Reproduction:
Initialize the database, enable "Gather Runtime Data" and then start playback.
I recomend using lossless files (in order to make rebuffering happen earlier).

On IRC it was suggested that this has to do with unbuffer callbacks.
http://www.rockbox.org/irc/reader.pl?date=20080110#15:02:07

H300 with r16046 and default settings (except for "Gather Runtime Data" and backlight timeout).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 18 February 2008, 06:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  should be fixed, repost if it still happens
Comment by Nicolas Pennequin (nicolas_p) - Thursday, 10 January 2008, 16:40 GMT
I'm pretty certain that this is due to the unbuffer callback for the track that was left partially buffered by the rebuffering. My sim showed access to the DB files when this callback happened. What I don't understand is why the disk would be accessed if the DB is in RAM...
Comment by Miika Pekkarinen (miipekk) - Tuesday, 22 January 2008, 17:10 GMT
Currently DB updates are always written to disk (just slightly delayed) when unbuffering callback occurs. It would be possible not to write to disk if DB is in RAM but that is not implemented yet.
Comment by Nicolas Pennequin (nicolas_p) - Sunday, 17 February 2008, 23:57 GMT
This should be fixed by r16330.

Loading...