Rockbox

Tasklist

FS#8506 - Plugging into USB Freezes Player

Attached to Project: Rockbox
Opened by Iain Dalton (iain) - Thursday, 24 January 2008, 03:02 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 07 April 2008, 13:06 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System PortalPlayer-based
Severity High
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Starting with rev 16105 (2008-01-19) (when some firmware changes were made), plugging into USB turns the screen black and makes the click wheel permanently glow, and I have to remove the battery to fix this. On some builds, it doesn't always do this. I haven't ascertained the reason. When it doesn't, a battery charging icon appears in the toolbar, so I assume the change has to do with allowing battery charging from Rockbox.

IMHO, the user should be able to choose whether Rockbox charges when plugged in, or reboots into the OF, as it did in revs 16099 (2008-01-18) and earlier.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 07 April 2008, 13:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  should be fixed now.. you may have to install the latest bootloader from svn though
2008-04-08: A request to re-open the task has been made. Reason for request: The link "http://rafb.net/p/djZ5mH54.html" do not work !
Comment by Jack Suter (chrisjs169) - Sunday, 17 February 2008, 00:12 GMT
I have indeed noticed this from time to time. It seems that it when Rockbox tries to reboot, it occasionally freezes. Keep in mind though, you can force the Sansa off by holding power for 15 seconds.
Comment by gillo (asper) - Wednesday, 26 March 2008, 22:46 GMT
Same problem as above (I did a duplicate bug-post because I was not able to find this one with the search engine).

I just installed today version (r6819) from r67xx (maybe r6729). My sansa e260 (refurbished, bought from USA - patched with sansapatcher downloaded 2 days ago, no custom modification) hangs when I try to connect the usb cable when rockbox is active. The system try to reset but hangs while the on screen image fades-out (sometime a black line appears in the middle of the screen)... it remains illuminated but nothing can be done. The only solution is to hold the power button for almost 10 seconds to shut the player down (someone suggested to remove the battery... very very unfair in sansa e260 !!! It is locked with screws !).
Only once an USB icon appeared but then everythings hanged like in the other cases (lcd fades out, etc.).
I never see the battery charging icon.

It normally works if I hold down the left button and boot with original firmware.
Comment by Christopher Williams (christop) - Monday, 31 March 2008, 10:01 GMT
I recently experienced a similar problem with r16884 and later but not with r16873 and earlier. When I plug in the USB cable in r16884 or later (at least up to r16899), the screen is garbled for a second, then it displays a big USB cable image in the middle of the screen on top of my background image, the status bar shows a USB icon, and the "hard drive LED" is on in the status bar. The system is frozen at this point. I can only hold the power button for about 12 seconds to shut it off.

The same thing also happens if I simply select "reconnect usb storage" in the System / Debug Menu, except the USB icon doesn't appear in the status bar (because it's not actually plugged in at the time it freezes).
Comment by Jonathan Gordon (jdgordon) - Monday, 31 March 2008, 10:16 GMT
confirmed on 2 of my 3 e200's (havnt tested on the third). a fix for the bootloader was commited a few days ago which may solve this also, ill have a little fiddle
Comment by Jonathan Gordon (jdgordon) - Monday, 31 March 2008, 10:29 GMT
yep... changing http://svn.rockbox.org/viewvc.cgi/trunk/firmware/target/arm/usb-fw-pp502x.c?r1=16816;r2=16817;pathrev=16817 from #ifndef BOOTLOADER to #ifndef SANSA_E200 fixes the problem. I dont know what problems might come up with this (probably a small battery hit)
Comment by Jonathan Gordon (jdgordon) - Monday, 31 March 2008, 10:45 GMT
flyspray spam!

I deleted my previous post because after actually testing the build it forced me to use recovery mode to get a working OF back... try the above change if you can...
Comment by Anthony (netman74501) - Tuesday, 01 April 2008, 01:43 GMT
I too get exactly what christop stated. It used to work when I had an older version. Can't remember which version, I know that it was far behind though so I decided to update. I liked being able to charge while listening to my music. Oh, well... I like the idea of being able to choose whether to reboot or charge when USB is plugged in. Never seen that before but I have only had mine from just after Christmas.
Comment by Jonathan Gordon (jdgordon) - Thursday, 03 April 2008, 01:53 GMT
why was this changed to PP targets? has anyone experienced this on any target other than the e200?
Comment by Marc Guay (Marc_Guay) - Thursday, 03 April 2008, 01:56 GMT
iPod 4G and Mini - See the related tasks. They are a bit older and possibly out of date, though. I got the impression that this was related to the PP USB stack rebooting being a bit hit-and-miss.
Comment by gillo (asper) - Thursday, 03 April 2008, 19:40 GMT
Will someone provide a fix for this ?
Comment by Dominik Riebeling (bluebrother) - Thursday, 03 April 2008, 19:53 GMT
I can't reproduce this issue on my Mini 2G (r16951).
Comment by Christopher Williams (christop) - Thursday, 03 April 2008, 20:38 GMT
My Sansa e280 now reboots correctly when the USB cable is inserted (or when "reconnect usb storage" is selected) with r16953.
Comment by Marc Guay (Marc_Guay) - Thursday, 03 April 2008, 20:43 GMT
My e200 hasn't done this in ages either, although it never consistently froze on me, so it's hard to say if it's just a matter of luck.
Comment by Jonathan Gordon (jdgordon) - Monday, 07 April 2008, 12:51 GMT
untill this gets commited try http://rafb.net/p/djZ5mH54.html

Loading...